Opened 4 years ago

Closed 4 years ago

#1237 closed defect (duplicate)

small audio file in MpegTs container cannot be open by ffmpeg.

Reported by: tfoucu Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Create a small audio silence file at low bitrate and output it to an mpeg2ts container

Something like this.
./ffmpeg -ac 1 -ar 22050 -f s16le -i /dev/zero -b:a 32k -f mpegts -t 1.5 -y /tmp/test.ts

it will create a file of small size (less than 8KBytes)
ls /tmp/test.ts
7520 2012-04-19 17:51 /tmp/test.ts

Then try to open it with ffmpeg and it will fail

./ffmpeg -i /tmp/test.ts
ffmpeg version N-39707-gf22bf52 Copyright (c) 2000-2012 the FFmpeg developers

built on Apr 10 2012 16:22:27 with gcc 4.4.3
configuration: --enable-nonfree --enable-version3 --enable-gpl --disable-mmx --enable-debug
libavutil 51. 46.100 / 51. 46.100
libavcodec 54. 14.101 / 54. 14.101
libavformat 54. 3.100 / 54. 3.100
libavdevice 53. 4.100 / 53. 4.100
libavfilter 2. 67.101 / 2. 67.101
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 11.100 / 0. 11.100
libpostproc 52. 0.100 / 52. 0.100

/tmp/test.ts: Operation not permitted

The problem is in mpegts_read_header function which require 8KBytes of data to process the file.

But this file is vallid.

Change History (1)

comment:1 Changed 4 years ago by cehoyos

  • Cc tfoucu@gmail.com removed
  • Keywords mpegts added
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #1094.

Note: See TracTickets for help on using tickets.