Opened 10 years ago

Closed 10 years ago

#1209 closed defect (worksforme)

library.mak:95: *** missing separator. Stop

Reported by: kuh3h3 Owned by:
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

tried to compile recent git ffmpeg on windows mingw.
but failed.

library.mak`s error line is


$(eval $(RULES))


License: nonfree and unredistributable
Creating config.mak and config.h...
/d/new-ffmpeg/mybuild/ffmpeg/library.mak:95: * missing separator. Stop.
32bit ffmpeg compilation failed.

Master@kuh3h3 /d/new-ffmpeg
$ make -v
GNU Make 3.81
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

This program built for i686-pc-msys

Master@kuh3h3 /d/new-ffmpeg
$ gcc -v
Using built-in specs.
COLLECT_GCC=D:\MSYS\mingw\bin\gcc.exe
COLLECT_LTO_WRAPPER=d:/msys/mingw/bin/../libexec/gcc/i686-pc-mingw32/4.6.2/lto-wrapper.exe
Target: i686-pc-mingw32
Configured with: ../src/configure --prefix=/mingw_new --build=i686-pc-mingw32 --target=i686-pc-mingw32 --with-sysroot=/mingw_new --with-buil
d-sysroot=/mingw_new --mandir=/mingw_new/i686-pc-mingw32/share/man --infodir=/mingw_new/i686-pc-mingw32/share/info --with-mpfr=/mingw_new/bu
ild_libs --with-gmp=/mingw_new/build_libs --with-ppl=/mingw_new/build_libs --enable-cloog-backend=isl --with-cloog=/mingw_new/build_libs --w
ith-mpc=/mingw_new/build_libs --with-host-libstdcxx='-lstdc++ -lsupc++ -lm' --with-pkgversion='XvidVideo.RU - GCC 4.6.2 i686-pc-mingw32' --w
ith-system-zlib --enable-static --enable-threads=win32 --enable-languages=c,c++,lto,objc,obj-c++ --enable-checking=release --enable-fully-dy
namic-string --enable-version-specific-runtime-libs --disable-rpath --disable-shared --disable-nls --disable-win32-registry --disable-werror

--disable-bootstrap

Thread model: win32
gcc version 4.6.2 (XvidVideo.RU - GCC 4.6.2 i686-pc-mingw32)

Master@kuh3h3 /d/new-ffmpeg
$

Change History (7)

comment:1 by Carl Eugen Hoyos, 10 years ago

Please provide the FFmpeg version you are using (first line of git log) and the configure line you tried.
Is the problem also reproducible with ./configure && make ?

comment:2 by yxmlines, 10 years ago

mingw/msys
Administrator@SERTLON /usr/temp/ffmpeg (master)
./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --arch=x86 --cpu=i686 --enable-runtime-cpudetect --enable-hardcoded-tables --enable-memalign-hack --enable-avisynth --enable-bzlib --enable-zlib --disable-doc
$ make
library.mak:95: * missing separator. Stop.
gcc -v
Using built-in specs.
COLLECT_GCC=D:\WinLinux\Minsys\Mingw\bin\gcc.exe
COLLECT_LTO_WRAPPER=d:/winlinux/minsys/mingw/bin/../libexec/gcc/mingw32/4.6.1/lt
o-wrapper.exe
Target: mingw32
Configured with: ../../src/gcc-4.6.1/configure --build=mingw32 --enable-language
s=c,c++,ada,fortran,objc,obj-c++ --enable-threads=win32 --enable-libgomp --enabl
e-lto --enable-fully-dynamic-string --enable-libstdcxx-debug --enable-version-sp
ecific-runtime-libs --with-gnu-ld --disable-nls --disable-win32-registry --disab
le-symvers --disable-werror --prefix=/mingw32tdm --with-local-prefix=/mingw32tdm

--enable-cxx-flags='-fno-function-sections -fno-data-sections' --with-pkgversio

n=tdm-1 --enable-sjlj-exceptions --with-bugurl=http://tdm-gcc.tdragon.net/bugs
Thread model: win32
gcc version 4.6.1 (tdm-1)

prompted to make/make clean and make distclean "library.mak: 95: * missing the separator. Stop" error, but only to use the git clone download the source.
The use of snapshots and linux/cygwin does not appear this error.
This error occurs only in the minsys/msys with git clone

7bb3a3-latest

Last edited 10 years ago by yxmlines (previous) (diff)

comment:3 by Carl Eugen Hoyos, 10 years ago

Is the problem also reproducible with ./configure && make ?

comment:4 by yxmlines, 10 years ago

yes

comment:5 by Clément Bœsch, 10 years ago

Could you try to:

git config --global core.autocrlf false

And checkout again the repository?

I'm wondering if the \r\n isn't at fault here...

comment:6 by yxmlines, 10 years ago

thanks ubitux
'library.mak: 95: * missing separator. Stop' the error no longer appears

Last edited 10 years ago by yxmlines (previous) (diff)

comment:7 by Clément Bœsch, 10 years ago

Resolution: worksforme
Status: newclosed

Great. I think libav has a pending patch to add an entry in the FAQ for this. If it doesn't get upstream soon, feel free to re-open this issue.

Note: See TracTickets for help on using tickets.