Opened 4 years ago

Closed 12 months ago

Last modified 11 months ago

#1057 closed enhancement (fixed)

support ffmpeg -targets

Reported by: dericed Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords: target
Cc: gajjanagadde@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It's difficult to discover what options the -target argument supports. I propose using a -targets argument to list the supported options (similar to ffmpeg -codecs or ffmpeg -formats).

ffmpeg -targets
ffmpeg version N-35274-g4272dc3 Copyright (c) 2000-2012 the FFmpeg developers
  built on Mar 11 2012 14:05:40 with gcc 4.2.1 (Apple Inc. build 5666) (dot 3)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/HEAD --enable-shared --enable-gpl --enable-version3 --enable-nonfree --enable-hardcoded-tables --enable-libfreetype --cc=/usr/bin/gcc-4.2 --enable-libx264 --enable-libfaac --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libass
  libavutil      51. 42.100 / 51. 42.100
  libavcodec     54. 10.100 / 54. 10.100
  libavformat    54.  2.100 / 54.  2.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 64.101 /  2. 64.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  7.100 /  0.  7.100
  libpostproc    52.  0.100 / 52.  0.100
Missing argument for option 'targets'

Change History (5)

comment:1 Changed 4 years ago by llogan

  • Priority changed from normal to wish
  • Status changed from new to open

The targets are currently listed in the help, "ffmpeg -h", under the -targets option and also in the man page, "man ffmpeg". Do you propose that the output of -target list more or other information that what the help supplies?

comment:2 Changed 4 years ago by dericed

Sorry, I only saw the ffmpeg -h version of this list

-target type        specify target file type ("vcd", "svcd", "dvd", "dv", "dv50", "pal-vcd", "ntsc-svcd", ...)

and assumed that the list was incomplete since it ended with a "...". The explanation of the target values in man ffmpeg is complete, right?

comment:3 Changed 4 years ago by llogan

Yes, the listing on the man page is complete (unless I missed something in ffmpeg.c). I can see how the ellipsis can be confusing, but it's attempting to indicate that the targets can be prefixed with "pal-", "ntsc-" or "film-". Do you think the wording in help should be changed?

comment:4 Changed 12 months ago by gajjanag

  • Cc gajjanagadde@gmail.com added
  • Resolution set to fixed
  • Status changed from open to closed

Merge from libav project:
530cd7a913b31dd563922d42ba575e8a3da02be1

clarifies this option.
I will therefore close this ticket; reopen if you feel the man page is still not clear enough.

comment:5 Changed 11 months ago by cehoyos

Remaining issue hould be fixed in a4188c9cd29a5bdea599e4c563eec6f6df496703

Note: See TracTickets for help on using tickets.