#10354 closed defect (invalid)

ffmpeg halt on scene after crop filter, some crop x variable

Reported by: Robert Owned by:
Priority: normal Component: avfilter
Version: 6.0 Keywords: scene after crop
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
If I use crop with scene filter, and use some float multiplier for crop x variable, ffmpeg halt and exit.

Above sample reproduce code first row is work, second row is halt, but one number diference.

How to reproduce:

ffmpeg -y -loglevel repeat+debug -hide_banner -f lavfi -i testsrc -vf  "crop=w=iw*0.4:x=in_w*0.20, select=gt(scene\,0.0004)"  -an -sn -dn fftest_a.mp4
ffmpeg -y -loglevel repeat+debug -hide_banner -f lavfi -i testsrc -vf  "crop=w=iw*0.4:x=in_w*0.21, select=gt(scene\,0.0004)"  -an -sn -dn fftest_a.mp4

ffmpeg version 6.0 or snapshot also
built on gyan.dev

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (1)

fflog.txt (6.2 KB ) - added by Robert 11 months ago.
without -hide_banner parameter

Download all attachments as: .zip

Change History (4)

comment:1 by Michael Koch, 11 months ago

I can't reproduce this isssue. Your command lines are running forever because -t option is missing. Please show the complete console output.

by Robert, 11 months ago

Attachment: fflog.txt added

without -hide_banner parameter

comment:2 by Robert, 11 months ago

Tryed another windows PC, and worked good, indefinitely. I don't now what the difference.

comment:3 by Michael Koch, 11 months ago

Resolution: invalid
Status: newclosed

Closed because it can't be reproduced.

Note: See TracTickets for help on using tickets.