Opened 7 years ago

Closed 6 years ago

#1028 closed defect (needs_more_info)

undefined reference to `cv::getOptimalDFTSize(int)'

Reported by: KSHawkEye Owned by:
Priority: important Component: ffmpeg
Version: 0.10 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm trying to compile FFmpeg 0.10 with opencv but I get:

i686-w64-mingw32-gcc -Llibavcodec -Llibavdevice -Llibavfilter -Llibavformat -Llibavutil -Llibpostproc -Llibswscale -Llibswresample -L/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib -Wl,--as-needed -Wl,--warn-common -Wl,-rpath-link=libpostproc:libswresample:libswscale:libavfilter:libavdevice:libavformat:libavcodec:libavutil -o ffmpeg_g.exe ffmpeg.o cmdutils.o -lavdevice -lavfilter -lavformat -lavcodec -lpostproc -lswresample -lswscale -lavutil -lavicap32 -lpsapi -lole32 -lstrmiids -luuid -lws2_32 -L/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib -L/home/kyle/software/ffmpeg/packages/zlib/zlib-1.2.6-win32/lib -lopencv_core231 -lopencv_imgproc231 -lopencv_highgui231 -lopencv_ml231 -lopencv_video231 -lopencv_features2d231 -lopencv_calib3d231 -lopencv_objdetect231 -lopencv_contrib231 -lopencv_legacy231 -lopencv_flann231 -lstdc++ -lz -lm -lpthread -lpsapi 
/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib/libopencv_imgproc231.a(templmatch.obj):templmatch.cpp:(.text$_ZN2cv9crossCorrERKNS_3MatES2_RS0_NS_5Size_IiEEiNS_6Point_IiEEdi+0x491): undefined reference to `cv::getOptimalDFTSize(int)'
/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib/libopencv_imgproc231.a(templmatch.obj):templmatch.cpp:(.text$_ZN2cv9crossCorrERKNS_3MatES2_RS0_NS_5Size_IiEEiNS_6Point_IiEEdi+0x4e1): undefined reference to `cv::getOptimalDFTSize(int)'
/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib/libopencv_imgproc231.a(templmatch.obj):templmatch.cpp:(.text$_ZN2cv9crossCorrERKNS_3MatES2_RS0_NS_5Size_IiEEiNS_6Point_IiEEdi+0xe27): undefined reference to `cv::dft(cv::_InputArray const&, cv::_OutputArray const&, int, int)'
/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib/libopencv_imgproc231.a(templmatch.obj):templmatch.cpp:(.text$_ZN2cv9crossCorrERKNS_3MatES2_RS0_NS_5Size_IiEEiNS_6Point_IiEEdi+0x1be4): undefined reference to `cv::dft(cv::_InputArray const&, cv::_OutputArray const&, int, int)'
/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib/libopencv_imgproc231.a(templmatch.obj):templmatch.cpp:(.text$_ZN2cv9crossCorrERKNS_3MatES2_RS0_NS_5Size_IiEEiNS_6Point_IiEEdi+0x1ccc): undefined reference to `cv::mulSpectrums(cv::_InputArray const&, cv::_InputArray const&, cv::_OutputArray const&, int, bool)'
/home/kyle/software/ffmpeg/packages/opencv/opencv-2.3.1-win32/lib/libopencv_imgproc231.a(templmatch.obj):templmatch.cpp:(.text$_ZN2cv9crossCorrERKNS_3MatES2_RS0_NS_5Size_IiEEiNS_6Point_IiEEdi+0x1d26): undefined reference to `cv::dft(cv::_InputArray const&, cv::_OutputArray const&, int, int)'
collect2: ld returned 1 exit status
make: *** [ffmpeg_g.exe] Error 1

I'm not sure if this issue is FFmpeg's, or opencv, but getOptimalDFTSize can be found in libopencv_imgproc231.a, and libopencv_core231.a. Both of which are included.

I can provide any further information needed.

Any ideas?

Change History (3)

comment:1 Changed 7 years ago by michael

Is this reproduceable with git master or specific to 0.10 ?

comment:2 Changed 7 years ago by michael

also complete command line used for configure is needed and config.* might be usefull too

comment:3 Changed 6 years ago by michael

  • Resolution set to needs_more_info
  • Status changed from new to closed

Missing used configure command line and config.mak/h/log. Also no reply since 3 months, thus closing. If this is still reproduceable please reopen and provide the needed information.
Thanks!

Note: See TracTickets for help on using tickets.