Opened 17 months ago

Last modified 8 months ago

#10250 new defect

libx265 -x265-params no-temporal-layers value not recognized

Reported by: AYUSA Owned by:
Priority: normal Component: ffmpeg
Version: 6.0 Keywords: ffmpeg libx265 x265 hevc
Cc: AYUSA Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: passing the "non-value" x265 param no-temporal-layers as "no-temporal-layers=1" is not recognized as valid per following message displayed when encoding is started. I tried setting to 0 as well with the same result.

[libx265 @ 0000020bdd835240] Invalid value for no-temporal-layers: 1.

How to reproduce:
I use an h264 1080p source in an MKV.

% "C:\ProgramData\chocolatey\lib\ffmpeg-full\tools\ffmpeg\bin\ffmpeg.exe" -loglevel info -an -y -hide_banner -i "clip.mkv" -crf 30.0 -preset veryfast -pix_fmt yuv420p10le -profile:v main10 -x265-params "no-temporal-layers=1:bframes=4:rc-lookahead=15:b-pyramid=1:subme=1:max-merge=2:min-keyint=24:keyint=240:ref=2:limit-refs=3:strong-intra-smoothing=0:rect=0:aq-mode=1:rd=4:psy-rd=0.75:psy-rdoq=4.0:rdoq-level=1:rskip=2:colorprim=bt709:transfer=bt709:colormatrix=bt709:chromaloc=0:no-sbrc=1:max-luma=1023" "clip.hevc"

ffmpeg version 6.0-full_build-www.gyan.dev Copyright (c) 2000-2023 the FFmpeg developers
built with gcc 12.2.0 (Rev10, Built by MSYS2 project)

Note that I checked with MediaInfo and the Encoding settings did list "temporal-layers=0" but not sure if that's essentially the same as using no-temporal-layers.

Please let me know if you need anything else or if I'm not doing something correctly in the command. Thank you.

Change History (3)

comment:1 by James, 16 months ago

I can't reproduce this. Both "no-temporal-layers=0" and "no-temporal-layers=1" are accepted here. It only complains about an invalid value if i use for example 2.
What version of libx265 are you using? My build prints:

x265 [info]: HEVC encoder version 3.4+31-6722fce1f

This is most likely not an ffmpeg bug as it's libx265 returning X265_PARAM_BAD_VALUE. If your libx265 build is older than mine, it would mean it's something they already fixed. But if it's newer, it would point at a recent regression from their side.

comment:2 by nonamepp, 11 months ago

I have the same problem with ffmpeg 6.0

[libx265 @ 000001883f96a440] Invalid value for no-temporal-layers: 1.

version info:

ffmpeg version 6.0-essentials_build-www.gyan.dev Copyright (c) 2000-2023 the FFmpeg developers

x265 [info]: HEVC encoder version 3.5+96-9c9ab68fc

Note: See TracTickets for help on using tickets.