#10079 closed defect (fixed)

libavcodec crash when decoding RTSP stream with VideoToolbox

Reported by: Alessandro Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: crash videotoolbox rtsp regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When using FFmpeg libavcodec to decode an RTSP stream on iOS, the library crashes when invoking videotoolbox_decoder_callback: the VTcontext pointer is null!

How to reproduce:
Reproduced this behavior on all the latest stable versions as well as master (commit 14c6093528).
Using RTSP test stream from rtsp://rtsp.stream/pattern.

It seems this commit 768d4c2e2a introduced the issue.
The decoding works fine, when using versions before this commit.

I'll try to submit a patch to ffmpeg-devel mailing list.

Attachments (2)

Screen Shot 2022-11-27 at 12.01.37.png (652.9 KB ) - added by Alessandro 19 months ago.
Crash exception
ffmpeg-logs-before-crash.log (91.6 KB ) - added by Alessandro 19 months ago.
FFmpeg logs before the crash

Download all attachments as: .zip

Change History (5)

by Alessandro, 19 months ago

Crash exception

by Alessandro, 19 months ago

FFmpeg logs before the crash

comment:1 by Carl Eugen Hoyos, 19 months ago

Keywords: regression added; ios removed

comment:2 by Alessandro, 19 months ago

Correction: The original commit that caused the issue is d7f4ad88a0df3c1339e142957bf2c40cd056b8ce.

Patch submitted to FFmpeg-devel.

comment:3 by quinkblack, 10 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.