Opened 7 days ago

Closed 6 days ago

Last modified 6 days ago

#7792 closed defect (needs_more_info)

duration line ignored

Reported by: jidanni Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Using
ffmpeg -f concat -i F -y /tmp/z.mp4
with file F:

file V_20190312_092245_vHDR_On.mp4
file V_20190312_092413_vHDR_On.mp4
file V_20190312_093018avHDR_On.mp4
file V_20190312_093018_vHDR_On.mp4
duration 3:30
file V_20190312_094155_vHDR_On.mp4
file V_20190312_094454_vHDR_On.mp4
file V_20190312_095415_vHDR_On.mp4
file V_20190312_100103_vHDR_On.mp4
file V_20190312_101016_vHDR_On.mp4

the duration line was ignored.

Change History (11)

comment:1 Changed 6 days ago by Gyan

How long is V_20190312_093018_vHDR_On.mp4 and what do you wish to achieve with the duration directive?

comment:2 Changed 6 days ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Version changed from 4.1 to unspecified

Please test current FFmpeg git head, provide the command line you tested together with its complete, uncut console output and ffmpeg -i output at least for the file for which you want to define a duration (or for all files) to make this a valid ticket.

comment:3 Changed 6 days ago by jidanni

In fact today I have a good Internet connection,
I can upload all 160 MB for you guys to play with.

comment:4 Changed 6 days ago by jidanni

Who / where / how would you like me to send them?
That would be the best way.
In a couple days I'm going back to my mountain, where such transfers would be impossible.

Last edited 6 days ago by jidanni (previous) (diff)

comment:5 Changed 6 days ago by jidanni

$ apt-cache policy $@
ffmpeg:

Installed: 7:4.1.1-1
Candidate: 7:4.1.1-1
Version table:

* 7:4.1.1-1 500

500 http://opensource.nchc.org.tw/debian unstable/main amd64 Packages

P.S., you can also see if the final product is playable to the end (not!).
In the end I was forced to use ffmpeg -t 210 to truncate that one video, before I uploaded them all as
separate files to
https://www.youtube.com/playlist?list=PLURD44UorvHTupNI16SX-HpLlhJsB-Nkl
having given up on dreams of gluing them together.

comment:6 Changed 6 days ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can provide the requested console output(s).

comment:7 follow-up: Changed 6 days ago by Cigaes

The duration directive in concat cannot be used to truncate a video. The inpoint and outpoint directives may be what you are looking for.

Also, this is a bug tracker, not a help forum; and only current Git Head is supported here, not releases patched by distributions.

comment:8 in reply to: ↑ 7 Changed 6 days ago by jidanni

Replying to Cigaes:

The duration directive in concat cannot be used to truncate a video.

OK, but please mention that very clearly at
https://ffmpeg.org/ffmpeg-all.html#Syntax-1
!!!
Thanks!

comment:9 Changed 6 days ago by jidanni

And as a matter of fact, users currently will think "that is what I am looking for" and not read further.
With the result being they, instead of truncating the file they intended, instead not only do not truncate it, but make the rest of the concatenation mysteriously non-playable beyond that component, due to ruined time information.
Hence even more need to make the documentation clear.

comment:10 Changed 6 days ago by Gyan

The name of the directive is a bit of a misnomer. It helps determine the offset for the start time of the *next* video, relative to the current one - useful in creating timestamp gaps to create a sparse input stream, like an image slideshow with varying durations.

comment:11 Changed 6 days ago by jidanni

Well all of this the user never imagined. Therefore it seems "duration"'s documentation there needs to be increased about five times more. Thanks.

Note: See TracTickets for help on using tickets.