Opened 9 months ago

Closed 9 months ago

#7748 closed defect (duplicate)

Encode to H.264 4:2:2 10 Bit doesn't work in mov container output

Reported by: swpleipzig Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When encoding using libx264 in 4:2:2 10 Bit (Pixformat yuv422p10le) you can create for example MP4 or TS output with no problem. But output to MOV creates a Quicktime Movie that is flagged as AVC-Intra (CodecID ai12) and doesn't play properly, because it is H.264 internally of course.
But we need that MOV-Container because its the only format that supports uncompressed audio streams.

At first we thougt Quicktime-MOVs dont support yuv422p10le - but for example the Panasonic GH5 camera writes exactly that format and it works with different editing systems.
Additionaly we tried to pipe the yuv422p10le-MP4 through ffmbc (just copy video and audio) and let ffmbc create a MOV out of that. That works too.

So should ffmpeg be able to create that kind of MOV too?

How to reproduce:

ffmpeg.exe -i source.mov -c:v libx264 -crf 18 -pix_fmt yuv422p10le -preset medium -tune film -level 41 -keyint_min 25 -g 50 -qmin 3 -qmax 51 -qdiff 4 -sn -n output.MOV

This creates that strange AVC-Intra MOV.
When changing File-Extension to MP4 or TS everything is fine.

ffmpeg version N-93075-gb429c86d84
built with gcc 8.2.1 (GCC) 20181201

but we tried even the 4.1.1 Release with same problem.

Change History (1)

comment:1 Changed 9 months ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords 10 Bit 4:2:2 MOV Quicktime removed
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 4.1 to unspecified

For future tickets: Please understand that only current FFmpeg git head is supported here and that a command line together with its complete, uncut console output is needed for every valid ticket.

Looks like a duplicate of ticket #7468.

Note: See TracTickets for help on using tickets.