Opened 7 months ago

Closed 7 months ago

#7658 closed defect (invalid)

m3u8 creation cuts of files if number of segments is greater 9

Reported by: nickpower Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: hls
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

How to reproduce:

% ffmpeg -i big_buck_bunny.y4m -c:v libx264 -crf 18 -g 48 -keyint_min 48 -force_key_frames 'expr:gte(t,n_forced*2)' -hls_time 2 palylist.m3u8

ffmpeg version: 3.4.4

Resulting m3u8 will be like:

#EXTM3U
#EXT-X-VERSION:3
#EXT-X-TARGETDURATION:2
#EXT-X-MEDIA-SEQUENCE:10
#EXTINF:2.000000,
palylist10.ts
#EXTINF:2.000000,
playlist11.ts
#EXTINF:2.000000,
playlist12.ts
...
#EXT-X-ENDLIST

So it does not contain playlist00.ts - playlist09 ...

Change History (4)

comment:1 Changed 7 months ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords segmentation dash split removed

Please test current FFmpeg git head and provide the command line you tested together with the complete, uncut console output to make this a valid ticket.

comment:2 follow-up: Changed 7 months ago by ePirat

It does not seem you set hls_list_size in your command line. As documented it defaults to 5, if you want all segments to be kept in the list you would need to set it to 0.

comment:3 in reply to: ↑ 2 Changed 7 months ago by nickpower

Replying to ePirat:

It does not seem you set hls_list_size in your command line. As documented it defaults to 5, if you want all segments to be kept in the list you would need to set it to 0.

Thanks. That worked. Why is the default 5? So it's not a bug.

comment:4 Changed 7 months ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.