Opened 2 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#7481 closed defect (fixed)

ffmpeg/ffprobe do not work with an FTP server

Reported by: boris-petrov Owned by:
Priority: important Component: avformat
Version: git-master Keywords: ftp regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Running ffmpeg/ffprobe on this FTP server causes them both to block for a minute or two and then output an "Input/output error":

% ffmpeg -i ftp://ffmpeg:ffmpeg2018@ftp.pbteu.com/ExportHD.mpg

Happens both on ffmpeg version 3.4.2 and on 4.0.2.

The FTP server is FileZilla? running on a Windows 7.

Change History (10)

comment:1 Changed 2 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords ftp regression added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

For future tickets: Please remember to always provide the command line you tested together with the complete, uncut console output and please always test current FFmpeg git head, nothing else is supported here.
Regression since a0358db323a89d976255567b909f4d18a7eb3461

$ ffmpeg -i ftp://ffmpeg:ffmpeg2018@ftp.pbteu.com/ExportHD.mpg
ffmpeg version N-92143-gb1504e7 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 6.4.0 (GCC)
  configuration: --enable-gpl --enable-gnutls --enable-libxml2
  libavutil      56. 19.101 / 56. 19.101
  libavcodec     58. 32.100 / 58. 32.100
  libavformat    58. 18.104 / 58. 18.104
  libavdevice    58.  4.105 / 58.  4.105
  libavfilter     7. 33.100 /  7. 33.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
[ftp @ 0x2fdde00] FTP open failed
ftp://ffmpeg:ffmpeg2018@ftp.pbteu.com/ExportHD.mpg: Input/output error

comment:2 Changed 6 weeks ago by cus

  • Resolution set to fixed
  • Status changed from open to closed

comment:3 Changed 6 weeks ago by cus

  • Resolution set to fixed
  • Status changed from open to closed

comment:4 follow-up: Changed 6 weeks ago by boris-petrov

Thank you for the support! Is this fix going to be in FFmpeg 4.0.4?

comment:5 in reply to: ↑ 4 Changed 6 weeks ago by cehoyos

Replying to boris-petrov:

Thank you for the support! Is this fix going to be in FFmpeg 4.0.4?

Please remember that all releases contain more bugs and less features than current FFmpeg git head and that there is no release support for Windows.

comment:6 follow-up: Changed 6 weeks ago by boris-petrov

I'm not sure I understand. Does that mean that git-head is more stable than a released version and should be used instead of one?

comment:7 in reply to: ↑ 6 Changed 6 weeks ago by cehoyos

Replying to boris-petrov:

I'm not sure I understand. Does that mean that git-head is more stable than a released version and should be used instead of one?

Yes, where did you find different information?

comment:8 Changed 6 weeks ago by boris-petrov

Well, I haven't read this anywhere, it's just that FFmpeg is the first project (or at least the first *major* one) that I've seen that suggests people to use "master" instead of a released version which is supposed to be stable so that's why I'm surprised. :) Do you run all your tests on every push to master? I'm just asking from curiosity - because otherwise how can you tell everyone to just clone the latest commit and compile from it and use that in production? :)

Anyway, thanks for the information and the fix!

comment:9 Changed 6 weeks ago by Gyan

Yes, regression tests are run on HEAD all the time. Plus a maintainer will (hopefully have) run one before push of a non-doc commit. See http://fate.ffmpeg.org/

comment:10 Changed 6 weeks ago by boris-petrov

I see, sounds great! Thanks to everyone for their time!

Note: See TracTickets for help on using tickets.