Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#7307 closed defect (needs_more_info)

MP4 HLS produce wrong m3u8/m4s

Reported by: loki5100 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: HLS
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When you run this command line on windows:


ffmpeg.exe -i "http://distribution.bbb3d.renderfarming.net/video/mp4/bbb_sunflower_1080p_30fps_normal.mp4" -loglevel verbose -c:a aac -b:a 128k -c:v hevc -b:v 4977k -maxrate 4977k -bufsize 7466k -x265-params "keyint=60:min-keyint=60:open-gop=0:scenecut=0" -r 483570000/16117951 -t 30 -sn -movflags faststart -preset ultrafast -pix_fmt yuv420p -hls_time 4 -hls_segment_type fmp4 -hls_list_size 0 -hls_flags single_file -hls_fmp4_init_filename C:\temp\ffmpeg\bbb_init.mp4 C:\temp\bbb.m3u8

Then when I try to play the .m3u8 in VLC media player it's crash and if I try to play the .m4s in VLC media player, i can't manually move the time cursor in the movie and vlc media player crash exactly at 29s of the beginning of playing

Change History (2)

comment:1 Changed 3 months ago by cehoyos

  • Keywords m3u8 m4s removed
  • Priority changed from critical to normal
  • Reproduced by developer unset
  • Resolution set to needs_more_info
  • Status changed from new to closed

Did you already report this to the vlc developers?

comment:2 Changed 3 months ago by loki5100

It's not vlc, because if you try to validate the .m3u8 with mediastreamvalidator (you can found it on MacOS) it's will failed. The .m4s is really wrong here...

Note: See TracTickets for help on using tickets.