Opened 2 months ago

Closed 2 months ago

#7252 closed defect (fixed)

SIGSEGV when the ffplay is terminated with Ctrl+C before video appears

Reported by: KTSamy Owned by:
Priority: important Component: ffplay
Version: git-master Keywords: SIGSEGV crash
Cc: cus Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When ffplay is closed using ctrl+c before the video surface appears, it results in with SIGSEGV in MacOS.

Can be reproduced with latest ffplay build from master branch.
Sample URL: "https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8"

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x000000000000002c
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]



Change History (11)

comment:1 Changed 2 months ago by cehoyos

  • Component changed from ffplay to undetermined
  • Keywords crash added; ffplay removed
  • Priority changed from normal to important
  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can provide backtrace, disassembly and register dump as explained on https://ffmpeg.org/bugreports.html

$ ffplay https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8
ffplay version N-91255-g7b80df6 Copyright (c) 2003-2018 the FFmpeg developers
  built with gcc 6.4.0 (GCC)
  configuration: --enable-gpl --enable-gnutls
  libavutil      56. 18.102 / 56. 18.102
  libavcodec     58. 20.100 / 58. 20.100
  libavformat    58. 17.100 / 58. 17.100
  libavdevice    58.  4.100 / 58.  4.100
  libavfilter     7. 25.100 /  7. 25.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
[hls,applehttp @ 0x7fd8c0000940] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/en/128kbit.m3u8' for reading
[https @ 0x7fd8c0015dc0] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/none/128kbit.m3u8' for reading
[https @ 0x7fd8c0015dc0] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/surround/en/320kbit.m3u8' for reading
[https @ 0x7fd8c0015dc0] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/none/128kbit.m3u8' for reading
[https @ 0x7fd8c0015dc0] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/250kbit.m3u8' for reading
[https @ 0x7fd8c0015dc0] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/500kbit.m3u8' for reading
^C
$

comment:2 follow-up: Changed 2 months ago by KTSamy

I am not much familiar with debugging tools. I have tried

sudo gdb ffplay_g
r -i https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8

the result was

(gdb) r -i https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8
Starting program: /usr/local/bin/ffplay_g -i https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8
[New Thread 0x1103 of process 68309]
[New Thread 0xf03 of process 68309]
Warning:
Cannot insert breakpoint -1.
Cannot access memory at address 0xf782

Command aborted.

I am not sure whether you have tried it on macOS or not. I am on Mac OS X 10.13.5 (17F77)

Here is my terminal output

ktsamy:~ thiru$ ffplay_g "https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8"
ffplay version 3.4.git Copyright (c) 2003-2018 the FFmpeg developers
  built with Apple LLVM version 9.0.0 (clang-900.0.39.2)
  configuration: --enable-static --disable-shared --disable-doc --enable-gpl --enable-version3 --enable-nonfree --enable-pthreads --pkg-config-flags=--static --enable-libxml2 --enable-gmp --enable-gnutls --enable-sdl2
  libavutil      56. 18.102 / 56. 18.102
  libavcodec     58. 20.100 / 58. 20.100
  libavformat    58. 17.100 / 58. 17.100
  libavdevice    58.  4.100 / 58.  4.100
  libavfilter     7. 25.100 /  7. 25.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
[hls,applehttp @ 0x1028a2000] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/en/128kbit.m3u8' for reading
Segmentation fault: 11=   0 aq=    0KB vq=    0KB sq=    0B f=0/0   
ktsamy:~ thiru$ ffplay_g "https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8"
ffplay version 3.4.git Copyright (c) 2003-2018 the FFmpeg developers
  built with Apple LLVM version 9.0.0 (clang-900.0.39.2)
  configuration: --enable-static --disable-shared --disable-doc --enable-gpl --enable-version3 --enable-nonfree --enable-pthreads --pkg-config-flags=--static --enable-libxml2 --enable-gmp --enable-gnutls --enable-sdl2
  libavutil      56. 18.102 / 56. 18.102
  libavcodec     58. 20.100 / 58. 20.100
  libavformat    58. 17.100 / 58. 17.100
  libavdevice    58.  4.100 / 58.  4.100
  libavfilter     7. 25.100 /  7. 25.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
[hls,applehttp @ 0x10306a800] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/en/128kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/none/128kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/surround/en/320kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/none/128kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/250kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/500kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/800kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/1100kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/1500kbit.m3u8' for reading
[https @ 0x1038f7200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/video/4000kbit.m3u8' for reading
Segmentation fault: 11=   0 aq=    0KB vq=    0KB sq=    0B f=0/0   
ktsamy:~ thiru$


I can even reproduce it with latest builds from https://ffmpeg.zeranoe.com/builds/

The following are the context from mac's bug reporting option context

Process:               ffplay_g [68095]
Path:                  /usr/local/bin/ffplay_g
Identifier:            ffplay_g
Version:               0
Code Type:             X86-64 (Native)
Parent Process:        bash [33400]
Responsible:           ffplay_g [68095]
User ID:               503

Date/Time:             2018-06-09 23:45:51.055 +0530
OS Version:            Mac OS X 10.13.5 (17F77)
Report Version:        12
Anonymous UUID:        BFD3E275-4331-9E14-9AE7-0B2DB68D4A72


Time Awake Since Boot: 4300 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x000000000000002c
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x2c:
--> 
    __TEXT                 0000000100000000-00000001016b7000 [ 22.7M] r-x/rwx SM=COW  /usr/local/bin/ffplay_g

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   ffplay_g                      	0x000000010000fba5 stream_cycle_channel + 21 (ffplay.c:3109)
1   ffplay_g                      	0x0000000100000000 0x100000000 + 0

Thread 1:: SDLTimer
0   libsystem_kernel.dylib        	0x00007fff7709ba1e __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff77264589 _pthread_cond_wait + 732
2   ffplay_g                      	0x0000000100fa0f6d SDL_CondWaitTimeout_REAL + 205
3   ffplay_g                      	0x0000000100fa0945 SDL_SemWaitTimeout_REAL + 181
4   ffplay_g                      	0x0000000100e82286 SDL_TimerThread + 614
5   ffplay_g                      	0x0000000100e81854 SDL_RunThread + 132
6   ffplay_g                      	0x0000000100fa03b5 RunThread + 21
7   libsystem_pthread.dylib       	0x00007fff77263661 _pthread_body + 340
8   libsystem_pthread.dylib       	0x00007fff7726350d _pthread_start + 377
9   libsystem_pthread.dylib       	0x00007fff77262bf9 thread_start + 13

Thread 2:
0   libsystem_kernel.dylib        	0x00007fff7709c292 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff7726320e _pthread_wqthread + 1552
2   libsystem_pthread.dylib       	0x00007fff77262be9 start_wqthread + 13

Thread 3:
0   libsystem_kernel.dylib        	0x00007fff7709c292 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff77263009 _pthread_wqthread + 1035
2   libsystem_pthread.dylib       	0x00007fff77262be9 start_wqthread + 13

Thread 4:
0   libsystem_kernel.dylib        	0x00007fff7709c292 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff7726320e _pthread_wqthread + 1552
2   libsystem_pthread.dylib       	0x00007fff77262be9 start_wqthread + 13

Thread 5:
0   libsystem_kernel.dylib        	0x00007fff7709225e semaphore_timedwait_trap + 10
1   libdispatch.dylib             	0x00007fff76f2194f _dispatch_sema4_timedwait + 72
2   libdispatch.dylib             	0x00007fff76f1994e _dispatch_semaphore_wait_slow + 58
3   libdispatch.dylib             	0x00007fff76f14e53 _dispatch_worker_thread + 251
4   libsystem_pthread.dylib       	0x00007fff77263661 _pthread_body + 340
5   libsystem_pthread.dylib       	0x00007fff7726350d _pthread_start + 377
6   libsystem_pthread.dylib       	0x00007fff77262bf9 thread_start + 13

Thread 6:
0   libsystem_kernel.dylib        	0x00007fff7709c292 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff7726320e _pthread_wqthread + 1552
2   libsystem_pthread.dylib       	0x00007fff77262be9 start_wqthread + 13

Thread 7:
0   libsystem_kernel.dylib        	0x00007fff7709c292 __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff77263009 _pthread_wqthread + 1035
2   libsystem_pthread.dylib       	0x00007fff77262be9 start_wqthread + 13

Thread 8:: read_thread
0   libsystem_kernel.dylib        	0x00007fff7709d0a2 poll + 10
1   ffplay_g                      	0x00000001002a1c23 ff_network_wait_fd_timeout + 371 (network.c:74)
2   ???                           	0x00000001026dc140 0 + 4335714624

Thread 9:: com.apple.NSEventThread
0   libsystem_kernel.dylib        	0x00007fff7709220a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff77091724 mach_msg + 60
2   com.apple.CoreFoundation      	0x00007fff4f1527d5 __CFRunLoopServiceMachPort + 341
3   com.apple.CoreFoundation      	0x00007fff4f151b27 __CFRunLoopRun + 1783
4   com.apple.CoreFoundation      	0x00007fff4f1511a3 CFRunLoopRunSpecific + 483
5   com.apple.AppKit              	0x00007fff4c826fc4 _NSEventThread + 184
6   libsystem_pthread.dylib       	0x00007fff77263661 _pthread_body + 340
7   libsystem_pthread.dylib       	0x00007fff7726350d _pthread_start + 377
8   libsystem_pthread.dylib       	0x00007fff77262bf9 thread_start + 13

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000100009c6d  rbx: 0x0000000000000000  rcx: 0x0000000000000048  rdx: 0x000000010000a03c
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x00007ffeefbff748  rsp: 0x00007ffeefbff6a0
   r8: 0x00000001024008b0   r9: 0x0000000000000040  r10: 0x00000001024008a8  r11: 0xffffffffffffffff
  r12: 0x0000000000000000  r13: 0x000000010c600000  r14: 0x00007ffeefbff744  r15: 0x000000010c600000
  rip: 0x000000010000fba5  rfl: 0x0000000000010246  cr2: 0x000000000000002c
  
Logical CPU:     2
Error Code:      0x00000004
Trap Number:     14


Model: MacBookPro13,1, BootROM MBP131.0220.B00, 2 processors, Intel Core i5, 2 GHz, 8 GB, SMC 2.36f97
Graphics: Intel Iris Graphics 540, Intel Iris Graphics 540, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, LPDDR3, 1867 MHz, 0x80AD, 0x483943434E4E4E424A544D4C41522D4E5544
Memory Module: BANK 1/DIMM0, 4 GB, LPDDR3, 1867 MHz, 0x80AD, 0x483943434E4E4E424A544D4C41522D4E5544
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x159), Broadcom BCM43xx 1.0 (7.77.37.31.1a9)
Bluetooth: Version 6.0.6f2, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
Thunderbolt Bus: MacBook Pro, Apple Inc., 33.2

Last edited 2 months ago by KTSamy (previous) (diff)

comment:3 in reply to: ↑ 2 ; follow-up: Changed 2 months ago by cehoyos

Replying to KTSamy:

ktsamy:~ thiru$ ffplay_g "https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8"
ffplay version 3.4.git Copyright (c) 2003-2018 the FFmpeg developers

Looks old and unsupported.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 2 months ago by KTSamy

Replying to cehoyos:

Replying to KTSamy:

ktsamy:~ thiru$ ffplay_g "https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8"
ffplay version 3.4.git Copyright (c) 2003-2018 the FFmpeg developers

Looks old and unsupported.

Nope. This was built from the recent master branch (Last commit is 7b80df677aa85c7d5cba457de915eac6108ec4e8 ). The RELEASE file of the master branch is not updated after the release of 4.0. That is leading to the confusion. I have already raised this on dev IRC sometime back.

As I mentioned earlier, I can reproduce the same on the builds from officially recommended sources (https://evermeet.cx/ffmpeg/ & https://ffmpeg.zeranoe.com/builds/ ). It looks like an issue with newer MacOS versions. I can even reproduce the issue with 3.4.X & 4.0 builds.

Last edited 2 months ago by KTSamy (previous) (diff)

comment:5 in reply to: ↑ 4 Changed 2 months ago by cehoyos

Replying to KTSamy:

Replying to cehoyos:

Replying to KTSamy:

ktsamy:~ thiru$ ffplay_g "https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8"
ffplay version 3.4.git Copyright (c) 2003-2018 the FFmpeg developers

Looks old and unsupported.

Nope. This was built from the recent master branch

In this case, you are using a broken source snapshot, try http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2

comment:6 follow-up: Changed 2 months ago by cehoyos

Feel free to test the following change:

diff --git a/fftools/ffplay.c b/fftools/ffplay.c
index 84ba667..5ace5cd 100644
--- a/fftools/ffplay.c
+++ b/fftools/ffplay.c
@@ -3106,7 +3106,11 @@ static void stream_cycle_channel(VideoState *is, int codec_type)
     int old_index;
     AVStream *st;
     AVProgram *p = NULL;
-    int nb_streams = is->ic->nb_streams;
+    int nb_streams;
+
+    if (!is->ic)
+        return;
+    nb_streams = is->ic->nb_streams;

     if (codec_type == AVMEDIA_TYPE_VIDEO) {
         start_index = is->last_video_stream;

comment:7 in reply to: ↑ 6 Changed 2 months ago by KTSamy

Replying to cehoyos:

Feel free to test the following change:

diff --git a/fftools/ffplay.c b/fftools/ffplay.c
index 84ba667..5ace5cd 100644
--- a/fftools/ffplay.c
+++ b/fftools/ffplay.c
@@ -3106,7 +3106,11 @@ static void stream_cycle_channel(VideoState *is, int codec_type)
     int old_index;
     AVStream *st;
     AVProgram *p = NULL;
-    int nb_streams = is->ic->nb_streams;
+    int nb_streams;
+
+    if (!is->ic)
+        return;
+    nb_streams = is->ic->nb_streams;

     if (codec_type == AVMEDIA_TYPE_VIDEO) {
         start_index = is->last_video_stream;

This fixes the issue. Thanks :)

comment:8 Changed 2 months ago by KTSamy

  • Component changed from undetermined to ffplay
  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

I have just realized that keys strokes are not captured by the terminal window as it was out of focus. The keys are captured by the ffplay & it results in SIGSEGV.

GDB 8.1 Seems to be broken on MacOS High Sierra. So, used 8.0.1 to collect the details you have requested. ffplay is build from the latest master branch (8c20ea8ee0).

ktsamy:ffmpeg-8c20ea8ee0 thiru$ gdb ffplay_g
GNU gdb (GDB) 8.0.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-apple-darwin17.6.0".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ffplay_g...done.
(gdb) r https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8
Starting program: /Users/Shared/Workspace/ffmpeg/Workspace/ffmpeg-8c20ea8ee0/ffplay_g https://bitdash-a.akamaihd.net/content/sintel/hls/playlist.m3u8
[New Thread 0xc03 of process 31172]
warning: unhandled dyld version (15)
ffplay version 3.4.git Copyright (c) 2003-2018 the FFmpeg developers
  built with Apple LLVM version 9.0.0 (clang-900.0.39.2)
  configuration: --enable-static --disable-shared --disable-doc --enable-gpl --enable-version3 --enable-nonfree --enable-pthreads --pkg-config-flags=--static --enable-libxml2 --enable-gmp --enable-gnutls --enable-sdl2
  libavutil      56. 18.102 / 56. 18.102
  libavcodec     58. 20.101 / 58. 20.101
  libavformat    58. 17.100 / 58. 17.100
  libavdevice    58.  4.100 / 58.  4.100
  libavfilter     7. 25.100 /  7. 25.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
[hls,applehttp @ 0x10300c200] Opening 'https://bitdash-a.akamaihd.net/content/sintel/hls/audio/stereo/en/128kbit.m3u8' for reading
[New Thread 0xa07 of process 31172]0KB vq=    0KB sq=    0B f=0/0
[New Thread 0x1503 of process 31172]
[New Thread 0x1603 of process 31172]
[New Thread 0x1703 of process 31172]
[New Thread 0x1803 of process 31172]
[New Thread 0x1903 of process 31172]
[New Thread 0x1a03 of process 31172]
[New Thread 0x2803 of process 31172]
[New Thread 0x2903 of process 31172]

Thread 2 received signal SIGSEGV, Segmentation fault.
stream_cycle_channel (is=0x10be00000, codec_type=0) at fftools/ffplay.c:3109
3109	    int nb_streams = is->ic->nb_streams;
(gdb) bt
#0  stream_cycle_channel (is=0x10be00000, codec_type=0) at fftools/ffplay.c:3109
#1  0x0000000100009a37 in event_loop (cur_stream=<optimized out>) at fftools/ffplay.c:3292
#2  main (argc=<optimized out>, argv=<optimized out>) at fftools/ffplay.c:3735
(gdb) disass $pc-32,$pc+32
Dump of assembler code from 0x10000f945 to 0x10000f985:
   0x000000010000f945 <stream_toggle_pause+501>:	add    $0x8,%rsp
   0x000000010000f949 <stream_toggle_pause+505>:	pop    %rbx
   0x000000010000f94a <stream_toggle_pause+506>:	pop    %rbp
   0x000000010000f94b <stream_toggle_pause+507>:	retq
   0x000000010000f94c:	nopl   0x0(%rax)
   0x000000010000f950 <stream_cycle_channel+0>:	push   %rbp
   0x000000010000f951 <stream_cycle_channel+1>:	push   %r15
   0x000000010000f953 <stream_cycle_channel+3>:	push   %r14
   0x000000010000f955 <stream_cycle_channel+5>:	push   %r13
   0x000000010000f957 <stream_cycle_channel+7>:	push   %r12
   0x000000010000f959 <stream_cycle_channel+9>:	push   %rbx
   0x000000010000f95a <stream_cycle_channel+10>:	push   %rax
   0x000000010000f95b <stream_cycle_channel+11>:	mov    %esi,%r12d
   0x000000010000f95e <stream_cycle_channel+14>:	mov    %rdi,%r15
   0x000000010000f961 <stream_cycle_channel+17>:	mov    0x48(%r15),%rdi
=> 0x000000010000f965 <stream_cycle_channel+21>:	mov    0x2c(%rdi),%r13d
   0x000000010000f969 <stream_cycle_channel+25>:	test   %r12d,%r12d
   0x000000010000f96c <stream_cycle_channel+28>:	je     0x10000f984 <stream_cycle_channel+52>
   0x000000010000f96e <stream_cycle_channel+30>:	cmp    $0x1,%r12d
   0x000000010000f972 <stream_cycle_channel+34>:	jne    0x10000f9aa <stream_cycle_channel+90>
   0x000000010000f974 <stream_cycle_channel+36>:	lea    0x10196c(%r15),%rax
   0x000000010000f97b <stream_cycle_channel+43>:	lea    0x16f0(%r15),%rcx
   0x000000010000f982 <stream_cycle_channel+50>:	jmp    0x10000f9b8 <stream_cycle_channel+104>
---Type <return> to continue, or q <return> to quit---
   0x000000010000f984 <stream_cycle_channel+52>:	mov    0x1018b8(%r15),%r14d
End of assembler dump.
(gdb) info all-registers
rax            0x100009a2d	4295006765
rbx            0x0	0
rcx            0x48	72
rdx            0x100009dfc	4295007740
rsi            0x0	0
rdi            0x0	0
rbp            0x7ffeefbff6e8	0x7ffeefbff6e8
rsp            0x7ffeefbff640	0x7ffeefbff640
r8             0x10271fbb0	4335991728
r9             0x40	64
r10            0x10271fba8	4335991720
r11            0xffffffffffffffff	-1
r12            0x0	0
r13            0x10be00000	4494196736
r14            0x7ffeefbff6e4	140732920755940
r15            0x10be00000	4494196736
rip            0x10000f965	0x10000f965 <stream_cycle_channel+21>
eflags         0x10246	[ PF ZF IF RF ]
cs             0x2b	43
ss             <unavailable>
ds             <unavailable>
es             <unavailable>
fs             0x0	0
gs             0x0	0
---Type <return> to continue, or q <return> to quit---
st0            -nan(0x00002cd37)	(raw 0xffff000000000002cd37)
st1            -nan(0x1ffffed351bef)	(raw 0xffff0001ffffed351bef)
st2            -nan(0x00001ffff)	(raw 0xffff000000000001ffff)
st3            0	(raw 0x00000000000000000000)
st4            0	(raw 0x00000000000000000000)
st5            5000000000	(raw 0x401f9502f90000000000)
st6            2575127221723	(raw 0x402895e462c576c00000)
st7            2575.1272217230001604360012379402178	(raw 0x400aa0f20919a53a05fb)
fctrl          0x37f	895
fstat          0x220	544
ftag           0xffff	65535
fiseg          0x7fff	32767
fioff          0x369b6db5	916155829
foseg          0x0	0
fooff          0x0	0
fop            0x0	0
xmm0           {v4_float = {0x15c28, 0x1, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x7b, 0x14, 0xae, 0x47, 0xe1, 0x7a, 0x84, 0x3f,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x147b, 0x47ae, 0x7ae1, 0x3f84, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x47ae147b,
    0x3f847ae1, 0x0, 0x0}, v2_int64 = {0x3f847ae147ae147b, 0x0}, uint128 = 0x00000000000000003f847ae147ae147b}
xmm1           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm2           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm3           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0,
---Type <return> to continue, or q <return> to quit---
    0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm4           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm5           {v4_float = {0x0, 0x1dfff, 0x0, 0x0}, v2_double = {0x8000000000000000, 0x0}, v16_int8 = {0x0, 0x0, 0x0, 0xe0, 0xff, 0xff,
    0xef, 0x47, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x0, 0xe000, 0xffff, 0x47ef, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {
    0xe0000000, 0x47efffff, 0x0, 0x0}, v2_int64 = {0x47efffffe0000000, 0x0}, uint128 = 0x000000000000000047efffffe0000000}
xmm6           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm7           {v4_float = {0x0, 0xffffffe7, 0x0, 0x0}, v2_double = {0xffffffffc0000001, 0x0}, v16_int8 = {0x0, 0x0, 0x80, 0xff, 0xff,
    0xff, 0xcf, 0xc1, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x0, 0xff80, 0xffff, 0xc1cf, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {
    0xff800000, 0xc1cfffff, 0x0, 0x0}, v2_int64 = {0xc1cfffffff800000, 0x0}, uint128 = 0x0000000000000000c1cfffffff800000}
xmm8           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x20, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x20, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x20, 0x0, 0x0, 0x0, 0x20, 0x0, 0x0, 0x0}, v4_int32 = {0x20, 0x0, 0x20, 0x0}, v2_int64 = {
    0x20, 0x20}, uint128 = 0x00000000000000200000000000000020}
xmm9           {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x24, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x24, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x24, 0x0, 0x0, 0x0, 0x24, 0x0, 0x0, 0x0}, v4_int32 = {0x24, 0x0, 0x24, 0x0}, v2_int64 = {
    0x24, 0x24}, uint128 = 0x00000000000000240000000000000024}
xmm10          {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x28, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x28, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x28, 0x0, 0x0, 0x0, 0x28, 0x0, 0x0, 0x0}, v4_int32 = {0x28, 0x0, 0x28, 0x0}, v2_int64 = {
    0x28, 0x28}, uint128 = 0x00000000000000280000000000000028}
xmm11          {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x2c, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2c, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x2c, 0x0, 0x0, 0x0, 0x2c, 0x0, 0x0, 0x0}, v4_int32 = {0x2c, 0x0, 0x2c, 0x0}, v2_int64 = {
    0x2c, 0x2c}, uint128 = 0x000000000000002c000000000000002c}
xmm12          {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x30, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x30, 0x0,
---Type <return> to continue, or q <return> to quit---
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x30, 0x0, 0x0, 0x0, 0x30, 0x0, 0x0, 0x0}, v4_int32 = {0x30, 0x0, 0x30, 0x0}, v2_int64 = {
    0x30, 0x30}, uint128 = 0x00000000000000300000000000000030}
xmm13          {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x34, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x34, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x34, 0x0, 0x0, 0x0, 0x34, 0x0, 0x0, 0x0}, v4_int32 = {0x34, 0x0, 0x34, 0x0}, v2_int64 = {
    0x34, 0x34}, uint128 = 0x00000000000000340000000000000034}
xmm14          {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x38, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x38, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x38, 0x0, 0x0, 0x0, 0x38, 0x0, 0x0, 0x0}, v4_int32 = {0x38, 0x0, 0x38, 0x0}, v2_int64 = {
    0x38, 0x38}, uint128 = 0x00000000000000380000000000000038}
xmm15          {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x3c, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x3c, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v8_int16 = {0x3c, 0x0, 0x0, 0x0, 0x3c, 0x0, 0x0, 0x0}, v4_int32 = {0x3c, 0x0, 0x3c, 0x0}, v2_int64 = {
    0x3c, 0x3c}, uint128 = 0x000000000000003c000000000000003c}
mxcsr          0x1fa1	[ IE PE IM DM ZM OM UM PM ]

comment:9 follow-up: Changed 2 months ago by cus

  • Cc cus added

There is an alternative patch in

http://mplayerhq.hu/pipermail/ffmpeg-devel/2018-June/231203.html

Could you try that as well?

comment:10 in reply to: ↑ 9 Changed 2 months ago by KTSamy

Replying to cus:

There is an alternative patch in

http://mplayerhq.hu/pipermail/ffmpeg-devel/2018-June/231203.html

Could you try that as well?

This patch also fixes the issue.

comment:11 Changed 2 months ago by cus

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in e8050aa79152899dbe50d4fb31e9303db8818cc2, thanks for testing.

Note: See TracTickets for help on using tickets.