Opened 3 weeks ago

Closed 3 weeks ago

#6875 closed defect (invalid)

ffmpeg not working with the windows docker container

Reported by: ankurvas Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Just run any command.
ffmpeg won't return any output.
But Windows returns the error -1073741701
Implies required dll’s is/are missing.
FFmpeg has the dependency on the following dll’s

  1. avicap32.dll
  2. msvfw32.dll

How can I resolve this issue?

Change History (3)

comment:1 Changed 3 weeks ago by heleppkes

Those libraries are available in a normal Windows installation, so if your environment doesn't have them, its not quite compatible.

From what I can tell, both of those are only used by the vfwcap input device, you could simply build ffmpeg without that component to avoid this issue.

comment:2 Changed 3 weeks ago by ankurvas

Hi,
Is there any way to do it in a docker file.

Regards,
Ankur Vashishtha

comment:3 Changed 3 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords dll's are missing removed
  • Priority changed from critical to normal
  • Resolution set to invalid
  • Status changed from new to closed

It is not a bug that FFmpeg by default depends on some system libraries.

Note: See TracTickets for help on using tickets.