Opened 2 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#6822 closed defect (fixed)

Cannot compile with --enable-decklink :

Reported by: Syl20 Owned by:
Priority: important Component: avdevice
Version: git-master Keywords: decklink
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi all,

First ticket here, sorry if incomplete.

I try to compile ffmpeg on MacOS with the --enable-decklink option :

./configure --prefix=/usr/local --enable-gpl --enable-nonfree --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libopus --enable-libxvid --enable-decklink --extra-cflags=-I/usr/local/include/ --extra-ldflags=-L/usr/local/lib/

configure script is OK but fail when I make :

libavdevice/decklink_dec.cpp:265:10: error: no previous prototype for function 'vanc_to_cc' [-Werror,-Wmissing-prototypes]
uint8_t *vanc_to_cc(AVFormatContext *avctx, uint16_t *buf, size_t words,
         ^
libavdevice/decklink_dec.cpp:355:10: error: no previous prototype for function 'get_metadata' [-Werror,-Wmissing-prototypes]
uint8_t *get_metadata(AVFormatContext *avctx, uint16_t *buf, size_t width,
         ^
In file included from libavdevice/decklink_dec.cpp:27:
In file included from ./libavformat/internal.h:27:
In file included from ./libavformat/avformat.h:319:
./libavcodec/avcodec.h:1375:16: warning: 'convergence_duration' is deprecated [-Wdeprecated-declarations]
typedef struct AVPacket {
               ^
./libavcodec/avcodec.h:1427:13: note: 'convergence_duration' has been explicitly marked deprecated here
    int64_t convergence_duration;
            ^
./libavcodec/avcodec.h:1375:16: warning: 'convergence_duration' is deprecated [-Wdeprecated-declarations]
typedef struct AVPacket {
               ^
./libavcodec/avcodec.h:1427:13: note: 'convergence_duration' has been explicitly marked deprecated here
    int64_t convergence_duration;
            ^
libavdevice/decklink_dec.cpp:706:25: warning: unused variable 'line_mask' [-Wunused-variable]
                int64_t line_mask = 1;
                        ^
3 warnings and 2 errors generated.
make: *** [libavdevice/decklink_dec.o] Error 1

I have succeed to do it before (June 2017) so I think it's a regression.

Thank for your help,

--
Sylvain

Change History (3)

comment:1 Changed 2 weeks ago by jamrial

  • Keywords decklink added; enable-decklink removed
  • Priority changed from normal to important
  • Status changed from new to open

Probably a regression since b6cf66ae1c4986f6d788a17233a6609b346c6aa6.

Patch sent to the ml.

comment:2 Changed 2 weeks ago by jamrial

  • Resolution set to fixed
  • Status changed from open to closed

comment:3 Changed 2 weeks ago by Syl20

Thank you for this. Now compilation is working, but can't still use the decklink device.

Same error as #4144

Note: See TracTickets for help on using tickets.