Opened 5 weeks ago

Closed 4 weeks ago

#6665 closed enhancement (wontfix)

Image sequence - feature request: add -end_number parameter

Reported by: edouardb Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords: image2
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

As per the FAQ (https://www.ffmpeg.org/faq.html#How-do-I-encode-single-pictures-into-movies_003f) there is a "-start_number" parameter that can be passed to start the encoding at a given frame/image sequence number.

I wish that there would be an "-end_number" parameter that could exist as well.

It would permit us to encode a portion of an image sequence.

At my studio it's normal to have 50 thousand frames in a given scene.
With that added parameter it would allow us to script ffmpeg to encode without moving/copying the rendered files selection in another folder.
The current behavior is to encode until there is no more files matching the digit (%d) parameter in the working folder.

Thanks.

Change History (2)

comment:1 Changed 5 weeks ago by cehoyos

What's wrong with -vframes?

comment:2 Changed 4 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords image2 added; image sequene removed
  • Priority changed from normal to wish
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version changed from unspecified to git-master

I don't think the option would have the desired effect: FFmpeg (the image2 muxer) would stop writing files but continue to decode and encode until the input stream ends. Adding the option to the command line tool doesn't work because it does not know the start number.
Use -vframes instead.

Note: See TracTickets for help on using tickets.