Opened 6 months ago

Closed 6 months ago

#6440 closed defect (duplicate)

Support and re-export of floating-point RGB-type color spaces (e.g. for YUV -based input)

Reported by: mtc Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

sYUV or sYCbCr-based color spaces' domain
contains colors that if transformed into sRGB that are often clipped or clamped
which discards the data but may be useful (defined in exif2.0 sYCC (most modern camera jpegs)) negative values represent values outside the RGB primaries, and for YUV incidentally, ceiling-clipping is most evident for blue-color channel (e.g. lightning pictures),
if ffmpeg supported openEXR output, perhaps, this data could be recovered (export to programs that support HDR),
also higher bit-precision (may avoid barely-noticible posterization banding fron rounding when transforming color space) it no dithering
used in highly smooth-low-noise areas

also paves way for xvYCC based support,
also note sRGB curve definitions for negative values how the function is defined.

use case include importing camera pictures that are overexposed in the RGB but not YUV channel thus blues seem washed out..

Change History (1)

comment:1 Changed 6 months ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Apparently a duplicate of ticket #3657.

Note: See TracTickets for help on using tickets.