Opened 2 years ago

Closed 2 years ago

#6120 closed defect (wontfix)

Transparency ignored in drawbox filter when using the overlay filter

Reported by: est77 Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: drawbox
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When using drawbox,transparency is ignored if the overlay filter is used later in the filter chain. This used to work in version 2.8 but it does not work anymore in 3.2 or master.

How to reproduce:

# Transparency ignored:
ffmpeg -thread_queue_size 512 -hwaccel auto -threads 0 -y -probesize 5000000 -r 25 -start_number 1 -i "bg.001.png" -i "logo.png" -filter_complex "[0:v]null,scale=960x540,drawbox=x=-52.8181818182:y=-1:w=1063.63636364:h=540:t=50:c=#000000@0.75[clip];[1:v]scale=iw*0.21:ih*0.21[logo];[clip][logo]overlay=851.05:1.05[clip];[clip]scale=960x540, fps=25, setdar=1.77777777778,setpts=PTS-STARTPTS[v]" -map [v] result_with_logo.png

# Correct transparency (but no overlay)
ffmpeg -thread_queue_size 512 -hwaccel auto -threads 0 -y -probesize 5000000 -r 25 -start_number 1 -i "bg.001.png" -filter_complex "[0:v]null,scale=960x540,drawbox=x=-52.8181818182:y=-1:w=1063.63636364:h=540:t=50:c=#000000@0.75,scale=960x540, fps=25, setdar=1.77777777778,setpts=PTS-STARTPTS[v]" -map [v] result_without_logo.png

Attachments (1)

drawbox_overlay_repro.zip (413.7 KB) - added by est77 2 years ago.
Files needed to reproduce and results

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by est77

Files needed to reproduce and results

comment:1 Changed 2 years ago by richardpl

This is because drawbox can now draw alpha directly. Use format=yuv444p after drawbox to avoid that.

comment:2 Changed 2 years ago by cehoyos

  • Keywords transparency overlay removed
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.