Opened 6 months ago

Closed 4 months ago

#6081 closed defect (fixed)

kVTCompressionPropertyKey_H264EntropyMode not available on osx 10.8

Reported by: cehoyos Owned by: kernrj
Priority: minor Component: avcodec
Version: git-master Keywords: osx
Cc: kagami Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

As reported by forum user tygerbug, trying to run a current ffmpeg binary on osx shows:

dyld: Symbol not found: _kVTCompressionPropertyKey_H264EntropyMode
  Referenced from: /Applications/ffmpeg
  Expected in: /System/Library/Frameworks/VideoToolbox.framework/Versions/A/VideoToolbox
 in /Applications/ffmpeg
Trace/BPT trap: 5

Change History (7)

comment:1 Changed 5 months ago by kernrj

  • Owner set to kernrj
  • Status changed from new to open

comment:2 Changed 4 months ago by kernrj

  • Resolution set to fixed
  • Status changed from open to closed

comment:3 Changed 4 months ago by kagami

Hi.

I'm still getting error Symbol not found: _kCVImageBufferColorPrimaries_ITU_R_2020 when trying to run latest ffmpeg on Maverics built on Sierra. libavcodec.dylib still includes references to such symbols:

$ nm -g libavcodec.57.dylib | grep R_2020
                 U _kCVImageBufferColorPrimaries_ITU_R_2020
                 U _kCVImageBufferTransferFunction_ITU_R_2020
                 U _kCVImageBufferYCbCrMatrix_ITU_R_2020

Do you know what might be the reason of that? These symbols are not available in 10.9 and linker obviously fails.

Problem goes away when I use --disable-videotoolbox configure option.

comment:4 Changed 4 months ago by cehoyos

  • Cc kagami added

Which version did you test?

comment:5 Changed 4 months ago by kagami

I built commit 7e4f32f4e4b93c95dcc872cb844c5548e69f352e with Homebrew on Sierra 10.12.3 and tested it on Maverics 10.9.5.

comment:6 Changed 4 months ago by kernrj

  • Resolution fixed deleted
  • Status changed from closed to reopened

I see the issue. Difficult to test on my setup.

comment:7 Changed 4 months ago by kernrj

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.