Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5958 closed defect (invalid)

ffmpeg statically build for arm6 throws illegal instruction on libx264 codec

Reported by: u007 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: libx264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -i /opt/webserver/video.h264 -itsoffset -00:00:00.4 -i /opt/webserver/audio.wav -c:v libx264 -crf 23 -c:a libfdk_aac -strict experimental -y /opt/webserver/public/videos-source/recording/rpi1.mp4
ffmpeg version 3.1.4-static
ffmpeg version 3.1.4-static http://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 5.4.1 (Debian 5.4.1-2) 20160904
  configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --enable-libmp3lame --enable-libx264 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --cc=gcc-5 --disable-ffplay
  libavutil      55. 28.100 / 55. 28.100
  libavcodec     57. 48.101 / 57. 48.101
  libavformat    57. 41.100 / 57. 41.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 47.100 /  6. 47.100
  libswscale      4.  1.100 /  4.  1.100
  libswresample   2.  1.100 /  2.  1.100
  libpostproc    54.  0.100 / 54.  0.100

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (3)

comment:1 Changed 2 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Resolution set to invalid
  • Status changed from new to closed

The FFmpeg project does not provide libx264.
Feel free to test with the x264 binary.

comment:2 Changed 2 years ago by u007

  • Component changed from undetermined to ffmpeg

due to raspberry pi 1 architecture, urgently need to have openmax enabled too

comment:3 Changed 2 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
Note: See TracTickets for help on using tickets.