Opened 3 years ago

Closed 3 years ago

#5865 closed defect (fixed)

ffplay doesn't correctly center fullscreen video on rotated monitor

Reported by: pdknsk Owned by:
Priority: normal Component: ffplay
Version: Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Open video on a rotated (pivot) monitor, example resolution: 1200x1920.
Press F.
The video is not centered, but shifted to the right past the screen, as if it were centered for a resolution of 1920x1920.

Change History (2)

comment:1 Changed 3 years ago by cus

This works for me, give some more info, like OS, SDL version, Window Manager, Display driver, etc.

comment:2 Changed 3 years ago by pdknsk

  • Resolution set to fixed
  • Status changed from new to closed

I'm on Ubuntu. Based on your comment I got the latest snapshot to try SDL2, which fixed the problem.

Note: See TracTickets for help on using tickets.