Opened 2 years ago

Closed 9 months ago

#5863 closed enhancement (fixed)

MXF file containing pcm from Ikegami gfpack

Reported by: cehoyos Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: mxf
Cc: cus Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

http://ffmpeg.org/pipermail/ffmpeg-user/2016-September/033705.html
A user uploaded an mxf file containing pcm_s16le that is not recognized by FFmpeg.

$ ffmpeg -loglevel verbose -i A2.MXF
ffmpeg version N-81755-g267da70 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      55. 30.100 / 55. 30.100
  libavcodec     57. 58.100 / 57. 58.100
  libavformat    57. 50.100 / 57. 50.100
  libavdevice    57.  0.102 / 57.  0.102
  libavfilter     6. 63.100 /  6. 63.100
  libswscale      4.  1.100 /  4.  1.100
  libswresample   2.  1.100 /  2.  1.100
  libpostproc    54.  0.100 / 54.  0.100
[mxf @ 0x35d52a0] Dark key 06.0e.2b.34.02.53.01.01.0d.01.01.01.01.01.23.00
[mxf @ 0x35d52a0] Dark key 06.0e.2b.34.01.01.01.02.03.01.02.10.01.00.00.00
[mxf @ 0x35d52a0] material track 1: has 2 components
[mxf @ 0x35d52a0] material track 2: has 2 components
[mxf @ 0x35d52a0] material track 3: has 2 components
Input #0, mxf, from 'A2.MXF':
  Metadata:
    uid             : 3631f14c-6bf0-4e33-9e5e-0a3acc167218
    generation_uid  : 27295f49-4a0e-0ad6-8b42-38c9bbf7b075
    company_name    : Ikegami
    product_name    : GF
    product_version : 1.0
    product_uid     : 4844532d-5631-3020-4141-363930363345
    modification_date: 2016-03-27T14:25:50.000000Z
    material_package_umid: 0x060A2B340101010501010D2013000000DE50491B0081A35CBF4756EFB5C90570
    timecode        : 00:00:00:00
  Duration: N/A, bitrate: N/A
At least one output file must be specified

Change History (5)

comment:2 Changed 2 years ago by cehoyos

Maybe a duplicate of ticket #4350.

comment:3 Changed 2 years ago by ahmed

Dear Cehoyos

the ticket number #4350 is about the video issue
this ticket is for the audio issue
thank you

comment:4 Changed 20 months ago by ahmed

Any one find the solution for the Audio file uploaded?
Thank you

comment:5 Changed 9 months ago by cus

  • Cc cus added
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 3aaf97e7737cab5d5476f70fd8405d5d330cb215, probably needed some of the earlier mxf patches as well.

Note: See TracTickets for help on using tickets.