Opened 3 years ago

Closed 3 years ago

#5757 closed defect (duplicate)

[Subtitle bug] ffmpeg can't load the subtitle file that isn't located in the same directory with ffmpeg.exe

Reported by: bordon Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

'Summary of the bug:'
[Subtitle bug] ffmpeg can't load the subtitle file that isn't located in the same directory with ffmpeg.exe

How to reproduce:
You can transcode a video file with a seperate subtile file.
When you put the subtitle file in the same directory with the ffmpeg.exe program,it work correctly. But when you put the subtitle file in a different directory with the ffmpeg.exe program,it didn't work and return the following errors:

[Parsed_subtitles_0 @ 0000000002bef840] Unable to open /movie/KB11-11-00.杈涚櫧鏋?Cymbeline.2014.1080p.BluRay???.x264.DTS-WiKi/Cymbeline???.2014.1080p.BluRay???.x264.DTS-WiKi???.srt

I'm looking forward the offical can solve the problem as soon as possible.

Through my research, I found it's the reason of libass library. I'm looking forward the offical can solve the problem as soon as possible. Thanks!

Change History (1)

comment:1 Changed 3 years ago by cehoyos

  • Analyzed by developer unset
  • Component changed from avfilter to undetermined
  • Keywords subtitle removed
  • Priority changed from critical to normal
  • Reproduced by developer unset
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from enhancement to defect

Sounds like a duplicate of ticket #5754.

Note: See TracTickets for help on using tickets.