Opened 3 years ago

Closed 3 years ago

#5625 closed defect (invalid)

ffmpeg showing NVENC unsupported on GeForce 930M.

Reported by: shivam543 Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: nvenc
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Summary of the bug:
I compiled ffmpeg on ubuntu 15.10 with nvidia-364 driver from graphics-drivers ppa. The driver is working fine.
I used nvidia nvenc 6.0.1 SDK.

How to reproduce:

ffmpeg -i input.mp4 -c:v nvenc_h264 -profile:v high444p -pixel_format yuv444p -preset default output.mp4


ffmpeg version N-80250-ge826cee Copyright (c) 2000-2016 the FFmpeg developers
built with gcc 4.9.3 (Ubuntu 4.9.3-5ubuntu1)
configuration: --enable-nonfree --enable-nvenc --extra-cflags=-I../cudautils --extra-ldflags=-L../cudautils --enable-gpl --enable-libx264 --enable-libmp3lame --prefix=/home/shivam/LocalRoot
libavutil      55. 24.100 / 55. 24.100
libavcodec     57. 45.100 / 57. 45.100
libavformat    57. 37.101 / 57. 37.101
libavdevice    57.  0.101 / 57.  0.101
libavfilter     6. 46.101 /  6. 46.101
libswscale      4.  1.100 /  4.  1.100
libswresample   2.  0.101 /  2.  0.101
libpostproc    54.  0.100 / 54.  0.100

built on Thu Jun  9 18:28:17 IST 2016

Attachments (1)

ffmpeg-20160609-183803.log (7.8 KB) - added by shivam543 3 years ago.
log of command speicified

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by shivam543

log of command speicified

comment:1 Changed 3 years ago by heleppkes

Some mobile systems, especially Optimus enabled ones, do not have access to the NVIDIA Video Processing features. Consult your laptops manufacturer if its supposed to be available.

comment:2 Changed 3 years ago by hendry

Argh, this is the only reason I chose the 06:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M] (rev a2) upgrade option on my T460s. :/

Last edited 3 years ago by hendry (previous) (diff)

comment:3 Changed 3 years ago by oromit

  • Analyzed by developer set
  • Component changed from undetermined to avcodec
  • Keywords nvenc added
  • Reproduced by developer set
  • Resolution set to invalid
  • Status changed from new to closed

I have the exact same situation on my T560.
As the Intel-GPU already has a video unit, they hard-disabled or even removed the one of the Nvidia card.
Talked with the Lenovo support about this, I'm not sure if they even understood what I was talking about, but there apparently is no way to do anything about this.

Anyway, not a bug in ffmpeg, nor anything it could do to help with the situation.

Note: See TracTickets for help on using tickets.