Opened 3 years ago

Closed 3 years ago

#5428 closed defect (fixed)

flac: file with big block size is not seekable in ffplay

Reported by: ami_stuff Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: flac seek regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by ami_stuff)

C:\>ffplay C:\32k.flac
ffplay version N-78758-g5156578 Copyright (c) 2003-2016 the FFmpeg developers
  built with gcc 5.3.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
ble-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --
enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-lib
x265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-d
ecklink --enable-zlib
  libavutil      55. 19.100 / 55. 19.100
  libavcodec     57. 27.100 / 57. 27.100
  libavformat    57. 26.100 / 57. 26.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 37.100 /  6. 37.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
Input #0, flac, from 'C:\32k.flac':0KB vq=    0KB sq=    0B f=0/0
  Duration: 00:00:13.50, start: 0.000000, bitrate: 975 kb/s
    Stream #0:0: Audio: flac, 44100 Hz, stereo, s16
Seek to 37% ( 0:00:04) of total duration ( 0:00:13)       B f=0/0
[flac @ 038c4c80] read_timestamp() failed in the middle
    Last message repeated 1 times
C:\32k.flac: error while seeking
Seek to 64% ( 0:00:08) of total duration ( 0:00:13)       B f=0/0
[flac @ 038c4c80] read_timestamp() failed in the middle
    Last message repeated 1 times
C:\32k.flac: error while seeking
Seek to 77% ( 0:00:10) of total duration ( 0:00:13)       B f=0/0
[flac @ 038c4c80] read_timestamp() failed in the middle
    Last message repeated 1 times
C:\32k.flac: error while seeking
   3.05 M-A:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0

Attachments (1)

32k.flac (1.6 MB) - added by ami_stuff 3 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by ami_stuff

  • Description modified (diff)
  • Summary changed from flac: file with big block size is not seekable to flac: file with big block size is not seekable in ffplay

Changed 3 years ago by ami_stuff

comment:2 Changed 3 years ago by cehoyos

  • Keywords flac seek regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

At least in some situations this is a regression since a5379d6e68cbdd894941d7962e72af890d41d1b7

comment:3 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.