Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5104 closed defect (fixed)

Assertion failure encoding with libschroedinger

Reported by: jamrial Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: libschroedinger regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

$ ./ffmpeg -i test.y4m -c:v libschroedinger -f null -
ffmpeg version N-77447-gb648b24 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 5.2.0 (Rev4, Built by MSYS2 project)
  configuration: --enable-gpl --enable-libschroedinger --prefix=/mingw64
  libavutil      55. 11.100 / 55. 11.100
  libavcodec     57. 20.100 / 57. 20.100
  libavformat    57. 20.100 / 57. 20.100
  libavdevice    57.  0.100 / 57.  0.100
  libavfilter     6. 21.101 /  6. 21.101
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
Input #0, yuv4mpegpipe, from 'test.y4m':
  Duration: 00:00:03.00, start: 0.000000, bitrate: 265156 kb/s
    Stream #0:0: Video: rawvideo (I420 / 0x30323449), yuv420p, 1280x720, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
Assertion *(const AVClass **)avctx->priv_data == codec->priv_class failed at /ffmpeg/src/libavcodec/utils.c:1563

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Change History (4)

comment:1 Changed 3 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

Regression since 2630f7f7 / be00ec83

comment:2 Changed 3 years ago by heleppkes

The context was missing an AVClass, I pushed a fix.

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.