Opened 3 years ago

Closed 2 years ago

#4985 closed enhancement (wontfix)

unoptimal performance of avdevice/lavfi (compared with -filter_complex)

Reported by: mfcc64 Owned by:
Priority: normal Component: avdevice
Version: git-master Keywords: lavfi
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Benchmark:

% time ffmpeg -loglevel debug -f lavfi -i "allrgb=d=10" -f rawvideo -y /dev/null
real    0m49.313s
user    0m36.170s
sys     0m12.982s

% time ffmpeg -loglevel debug -filter_complex "allrgb=d=10" -f rawvideo -y /dev/null
real    0m26.774s
user    0m20.389s
sys     0m6.290s

I suggest this because of data copying, probably it should use wrapped_frame.

Thanks.

Change History (1)

comment:1 Changed 2 years ago by mfcc64

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.