Opened 4 years ago

Closed 4 years ago

#4968 closed defect (invalid)

ffmpeg-0.6.1: allocations filling process address space of 4GB, sets errno = ENOMEM

Reported by: satyajitr Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
ffmpeg is being used as shared libraries by the application.
Plays a 104 second long h264 42801F clip and abruptly terminates after 20 seconds.
File is played 340 times simultaneously for 9 hours.
The heap piles up and process address space is filled and sets ENOMEM, denying further allocations.
But if the file plays completely for 104 secs ,the allocations are released properly.

How to reproduce:

% 
Plays a 104 second long h264 42801F clip and abruptly terminates after 20 seconds.
File is played 340 times simultaneously for 9 hours.
The heap piles up and process address space is filled and sets ENOMEM, denying further allocations.
But if the file plays completely for 104 secs ,the allocations are released properly.
ffmpeg 0.6.1
built on RHEL 5 and 6.

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (1)

comment:1 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Please reopen this ticket if the issue is reproducible with current FFmpeg git head, version 0.6 is not supported for a long time.

Note: See TracTickets for help on using tickets.