Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#4705 closed defect (invalid)

this FLAC song pops and cracks during playback

Reported by: andrewrk Owned by:
Priority: normal Component: avcodec
Version: 2.6.3 Keywords: flac
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

https://s3.amazonaws.com/superjoe/temp/rythmortis.flac

  • listen to it with ffplay and hear pops and cracks
  • listen to it with vlc, no pops and cracks

upstream bug report: https://github.com/andrewrk/libgroove/issues/86
libav bug report: https://bugzilla.libav.org/show_bug.cgi?id=857

Tested with this ffplay version:

ffplay version 2.6.3 Copyright (c) 2003-2015 the FFmpeg developers
built with gcc 4.8.4 (GCC)
configuration: --disable-static --prefix=/nix/store/5rhxr5g4n554swpmlgd7x7cfprq4if5z-ffmpeg-2.6.3 --enable-gpl --enable-version3 --disable-nonfree --enable-shared --disable-static --enable-pic --disable-small --enable-runtime-cpudetect --enable-gray --enable-swscale-alpha --disable-incompatible-libav-abi --enable-hardcoded-tables --enable-safe-bitstream-reader --disable-memalign-hack --enable-pthreads --disable-w32threads --disable-os2threads --enable-network --enable-pixelutils --enable-ffmpeg --enable-ffplay --enable-ffprobe --enable-ffserver --enable-avcodec --enable-avdevice --enable-avfilter --enable-avformat --enable-avresample --enable-avutil --enable-postproc --enable-swresample --enable-swscale --enable-doc --disable-htmlpages --enable-manpages --disable-podpages --disable-txtpages --enable-bzlib --enable-libcelt --disable-libfaac --disable-libfdk-aac --disable-libflite --enable-fontconfig --enable-libfreetype --enable-frei0r --enable-libfribidi --enable-libgme --enable-gnutls --enable-libgsm --enable-ladspa --enable-libmp3lame --enable-libass --enable-libbluray --enable-libbs2b --enable-libdc1394 --enable-iconv --enable-libmodplug --enable-libopus --enable-libssh --enable-libtheora --enable-libv4l2 --enable-vaapi --enable-vdpau --enable-libvorbis --enable-libvpx --enable-libwebp --enable-xlib --enable-libxcb --enable-libxcb-shm --enable-libxcb-xfixes --enable-libxcb-shape --enable-lzma --enable-openal --disable-opengl --enable-libopenjpeg --disable-openssl --enable-libpulse --enable-librtmp --enable-libsmbclient --enable-sdl --enable-libsoxr --enable-libspeex --enable-libvidstab --enable-libwavpack --disable-x11grab --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzmq --enable-zlib --disable-debug --enable-optimizations --disable-extra-warnings --disable-stripping
libavutil      54. 20.100 / 54. 20.100
libavcodec     56. 26.100 / 56. 26.100
libavformat    56. 25.101 / 56. 25.101
libavdevice    56.  4.100 / 56.  4.100
libavfilter     5. 11.102 /  5. 11.102
libavresample   2.  1.  0 /  2.  1.  0
libswscale      3.  1.101 /  3.  1.101
libswresample   1.  1.100 /  1.  1.100
libpostproc    53.  3.100 / 53.  3.100

Change History (2)

comment:1 Changed 4 years ago by cehoyos

  • Keywords flac added
  • Resolution set to invalid
  • Status changed from new to closed

Please test current FFmpeg git head before reporting issues, see https://ffmpeg.org/bugreports.html

comment:2 Changed 4 years ago by andrewrk

I apologize for not testing with ffmpeg master. I tested with a137e50ee54cd902c436d15463c6e621623cc9ad and indeed the problem was fixed.

Note: See TracTickets for help on using tickets.