Opened 3 years ago

Closed 3 years ago

#4224 closed defect (invalid)

ffprobe doesn't show the TAG: in the FORMAT section

Reported by: simon-r Owned by:
Priority: normal Component: ffprobe
Version: unspecified Keywords: show_format tag ogg vorbis
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes

Description

Summary of the bug:

If we perform
ffprobe -show_format audio.ogg
on an ogg vorbis audio file it doesn't print the TAG: in the format ( [FORMAT] ... FORMAT ) section.

An example:

How to reproduce:

ffprobe -show_format 15\ Variazioni\ e\ fuga\ in\ mi\ bemolle\ maggiore\ op.\ 35\ \'Eroica\'\ -\ Introduzione.ogg 
ffprobe version 2.5.2 Copyright (c) 2007-2014 the FFmpeg developers
  built on Dec 26 2014 11:50:46 with gcc 4.9.2 (GCC)
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-avisynth --enable-avresample --enable-fontconfig --enable-gnutls --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-runtime-cpudetect --enable-shared --enable-swresample --enable-vdpau --enable-version3 --enable-x11grab
  libavutil      54. 15.100 / 54. 15.100
  libavcodec     56. 13.100 / 56. 13.100
  libavformat    56. 15.102 / 56. 15.102
  libavdevice    56.  3.100 / 56.  3.100
  libavfilter     5.  2.103 /  5.  2.103
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
Input #0, ogg, from '15 Variazioni e fuga in mi bemolle maggiore op. 35 'Eroica' - Introduzione.ogg':
  Duration: 00:04:41.87, start: 0.000000, bitrate: 459 kb/s
    Stream #0:0: Audio: vorbis, 44100 Hz, stereo, fltp, 499 kb/s
    Metadata:
      ALBUM           : Beethoven - Variations - Bagatelles
      ARTIST          : Glenn Gould
      COMPILATION     : false
      COMPOSER        : Ludwig Van Beethoven
      comment         : Track 1
      GENRE           : Classical
      TITLE           : 15 Variazioni e fuga in mi bemolle maggiore op. 35 'Eroica' - Introduzione
      track           : 01
[FORMAT]
filename=15 Variazioni e fuga in mi bemolle maggiore op. 35 'Eroica' - Introduzione.ogg
nb_streams=1
nb_programs=0
format_name=ogg
format_long_name=Ogg
start_time=0.000000
duration=281.866667
size=16197001
bit_rate=459706
probe_score=100
[/FORMAT]

Change History (1)

comment:1 Changed 3 years ago by saste

  • Analyzed by developer set
  • Resolution set to invalid
  • Status changed from new to closed

That's because the metadata is stored in the stream, rather than in the format container. Use -show_streams or equivalent. Reopen the ticket only if this is not working as expected.

Note: See TracTickets for help on using tickets.