Opened 5 years ago

Closed 5 years ago

#4109 closed defect (fixed)

"Not a valid DCA frame" error reading WAV file

Reported by: pneuman Owned by:
Priority: important Component: avformat
Version: git-master Keywords: wav dca probe regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

When trying to open a particular WAV file (which I'd just decoded from a FLAC file using the "flac" tool), ffmpeg produces a string of errors, starting with "Not a valid DCA frame". This is with the latest source from git:

lsd@debian:~/ffmpeg$ ./ffmpeg/ffmpeg -i blah-snippet.wav 
ffmpeg version N-67658-ge6e6149 Copyright (c) 2000-2014 the FFmpeg developers
  built on Nov 14 2014 13:30:02 with gcc 4.9.1 (Debian 4.9.1-19)
  configuration: 
  libavutil      54. 11.100 / 54. 11.100
  libavcodec     56. 12.100 / 56. 12.100
  libavformat    56. 12.103 / 56. 12.103
  libavdevice    56.  3.100 / 56.  3.100
  libavfilter     5.  2.103 /  5.  2.103
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
[dca @ 0x313c560] Not a valid DCA frame
[dca @ 0x313c560] ERROR: block code look-up failed
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
    Last message repeated 1 times
[dca @ 0x313c560] Invalid LFE value: 0
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
    Last message repeated 1 times
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
[dca @ 0x313c560] LFEScaleIndex larger than 127 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[dca @ 0x313c560] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[dca @ 0x313c560] error decoding block
    Last message repeated 1 times
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] ERROR: block code look-up failed
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
    Last message repeated 1 times
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
    Last message repeated 1 times
[dca @ 0x313c560] Non standard configuration 53 !
[dca @ 0x313c560] Didn't get subframe DSYNC
[dca @ 0x313c560] error decoding block
    Last message repeated 1 times
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
    Last message repeated 2 times
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
[dca @ 0x313c560] Invalid bit allocation index
[dca @ 0x313c560] error decoding block
[dca @ 0x313c560] Invalid LFE value: 0
[dca @ 0x313c560] LFEScaleIndex larger than 127 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[dca @ 0x313c560] If you want to help, upload a sample of this file to ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[dca @ 0x313c560] error decoding block
    Last message repeated 1 times
[wav @ 0x313bb60] decoding for stream 0 failed
[wav @ 0x313bb60] Could not find codec parameters for stream 0 (Audio: dts (DTS) ([1][0][0][0] / 0x0001), 192000 Hz, 2 channels (FL+FR+LFE), fltp, 0 kb/s): no decodable DTS frames
Consider increasing the value for the 'analyzeduration' and 'probesize' options
blah-snippet.wav: could not find codec parameters
Input #0, wav, from 'blah-snippet.wav':
  Duration: 00:00:05.00, bitrate: 1411 kb/s
    Stream #0:0: Audio: dts (DTS) ([1][0][0][0] / 0x0001), 192000 Hz, 2 channels (FL+FR+LFE), fltp, 0 kb/s
At least one output file must be specified

I'll attach a sample of the file, which is enough to trigger the issue.

Thanks
Leigh

Attachments (1)

blah-snippet.wav (861.4 KB) - added by pneuman 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by pneuman

comment:1 Changed 5 years ago by cehoyos

  • Keywords wav dca probe regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

Regression since 549bbdfb - related to ticket #3550.

comment:2 Changed 5 years ago by cehoyos

  • Keywords regression removed
  • Priority changed from important to normal

What kind of sample is this? It doesn't sound like a wav file to me when played with an older version of FFmpeg.

comment:3 Changed 5 years ago by pneuman

Hi,

I hadn't actually listened to the sample until just now -- I can understand your confusion! Here it is, in context -- it's the first track on this album:

https://lavachurch.bandcamp.com/album/sterile-daggers

They've tagged their album "ambient drone", "harsh noise", etc. so I can only assume that how it sounds when played as a regular WAV is exactly what it's meant to sound like. That's definitely how the streaming MP3 on our site sounds, and it's likely that the band and/or label have previewed the stream and found no cause for concern.

comment:4 Changed 5 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important

Thank you for the explanation: I was sure it was data muxed in a wav file...

comment:5 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.