Opened 5 years ago

Closed 5 years ago

#4040 closed defect (fixed)

mxf decoding regression

Reported by: cehoyos Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mxf regression videolan
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

(videolan ticket 12324)

A videolan user uploaded a mxf sample that cannot be demuxed with libavformat. At least for audio this is a regression since 1c010fd0 - related to ticket #3278.

$ ffmpeg -i AVC-LongG_25_1080-59.94i.MXF
ffmpeg version N-66963-g75c8d7c Copyright (c) 2000-2014 the FFmpeg developers
  built on Oct 17 2014 23:42:33 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      54. 10.100 / 54. 10.100
  libavcodec     56.  8.102 / 56.  8.102
  libavformat    56.  9.100 / 56.  9.100
  libavdevice    56.  1.100 / 56.  1.100
  libavfilter     5.  1.106 /  5.  1.106
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
[mxf @ 0x3083ba0] MXF structure loop detected
AVC-LongG_25_1080-59.94i.MXF: Invalid data found when processing input

Change History (2)

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by Tomas Härdin in 37c36861

Note: See TracTickets for help on using tickets.