Opened 3 years ago

Closed 6 months ago

#3875 closed defect (invalid)

Cannot seek MP4 with HEVC

Reported by: Krakean Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: mov hevc
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Sample: http://webfile.ru/c86ae7d294464db9d7c6a844634f138c (press green "Скачать" button)

Playback stutters and unable to seek.

Change History (2)

comment:1 Changed 3 years ago by muken

The sample has only one entry within the sync sample table.
This means that you can only seek to the first picture.
And this is not an issue of the libavformat demuxer since the sample contains 5 CRA pictures and they can be marked as a sync sample according to the 14496-15 3rd ed..
This is an issue of the muxer which made this sample.
So, blame the muxer.

To all appearance, the muxer is MP4Box since the sample contains a weird brand, hvc1.

Wrong:
[stss: Sync Sample Box]

version = 0
flags = 0x000000
entry_count = 1
sample_number[0] = 1

Correct:
[stss: Sync Sample Box]

version = 0
flags = 0x000000
entry_count = 6
sample_number[0] = 1
sample_number[1] = 247
sample_number[2] = 497
sample_number[3] = 747
sample_number[4] = 997
sample_number[5] = 1247

comment:2 Changed 6 months ago by cehoyos

  • Keywords mov hevc added
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.