Opened 6 years ago

Closed 6 years ago

#3419 closed defect (duplicate)

-ss on the input has no effect when extracting subtitles

Reported by: bubbleguuum Owned by:
Priority: normal Component: avformat
Version: 2.1.3 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

uUing the -ss option to specify the start of the input has no effect when extracting subtitles. The full subtitle extracted, not taking into account the start position:

% ffmpeg  -i h264_720p_hp_5.1_3mbps_vorbis_styled_and_unstyled_subs_suzumiya.mkv -map 0:2 -c:0 srt -f srt sub1.srt

% ffmpeg -ss 10 -i h264_720p_hp_5.1_3mbps_vorbis_styled_and_unstyled_subs_suzumiya.mkv -map 0:2 -c:0 srt -f srt sub2.srt

both files sub1.srt and sub2.srt are identical.
I would have expected sub2.srt timestamps to be offset by -10 seconds, and all cues < 10s to be discarded.

The file used for testing can be found here:
http://www.auby.no/files/video_tests/h264_720p_hp_5.1_3mbps_vorbis_styled_and_unstyled_subs_suzumiya.mkv

Change History (1)

comment:1 Changed 6 years ago by cehoyos

  • Keywords srt subitle removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #2067

For future tickets: Please always test current git head before reporting bugs here and please always add the complete, uncut console output for failing command lines.

Note: See TracTickets for help on using tickets.