Opened 5 years ago

Closed 5 years ago

#3279 closed defect (worksforme)

artefacts on ffh264_vdpau decoder.

Reported by: pawels80 Owned by:
Priority: normal Component: undetermined
Version: 2.1.1 Keywords: vdpau
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

during playing h264 example i'm observing artefacts with ffh264_vdpau decoder.
artefacts (bright square glitches on the rocks) recorded with handycam are visible on the second video.

with the ffh264 decoder the example looks fine.

How to reproduce:

% DRI_PRIME=1 mplayer -vo vdpau -vc ffh264vdpau rocks.mkv -nosub -fs

rocks.mkv:
http://www.datafilehost.com/d/82ca3b4a

artefacts:
http://www.datafilehost.com/d/263dd2e4

ffmpeg-libs-2.1.1-1.fc20.x86_64
libvdpau-0.7-1.fc20.x86_64
libva-vdpau-driver-0.7.4-6.fc20.x86_64
mesa-vdpau-drivers-9.2.5-1.20131220.fc20.x86_64
mplayer-1.1-16.20131125svn.fc20.x86_64

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Keywords vdpau added
  • Resolution set to worksforme
  • Status changed from new to closed

(Both your MPlayer and FFmpeg version look old.)

Does it work with -vc ffh264vdpauold? Does it work with other versions of FFmpeg and MPlayer?

Since this works fine here (with the proprietary NVidia driver), I would suggest that you report the problem to the mesa driver developers.

Note that from my MPlayer developer pov, only MPlayer binaries with static FFmpeg libraries are supported.

Note: See TracTickets for help on using tickets.