Opened 6 years ago

Closed 6 years ago

#3225 closed enhancement (fixed)

Enable tags in wiki pages

Reported by: saste Owned by:
Priority: normal Component: trac
Version: unspecified Keywords: tags trac
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Tags have been added to mark tickets.

Adding tags to wiki articles will help with providing a flexible form of categorization to content and will help to visualize the covered topics.

Change History (3)

comment:1 follow-up: Changed 6 years ago by beastd

  • Status changed from new to open

If I activate tagging for the wiki the tags page (reachable through the
main navigation bar) will by default have a merged tag cloud from both
the wiki and ticket tags.

But filtering can be used to restrict the view to either realm. The filtering
can be controlled through check boxes and then hitting the "Filter Tags" button
to refresh the view.

If that is OK, I can enable wiki tagging.

comment:2 in reply to: ↑ 1 Changed 6 years ago by saste

Replying to beastd:

If I activate tagging for the wiki the tags page (reachable through the
main navigation bar) will by default have a merged tag cloud from both
the wiki and ticket tags.

I think that makes sense, since "Tags" are not necessarily related to wiki or tickets, and trac handles both.

But filtering can be used to restrict the view to either realm. The filtering
can be controlled through check boxes and then hitting the "Filter Tags" button
to refresh the view.

If that is OK, I can enable wiki tagging.

I think it is fine if the interface can be conveniently tweaked to select either one of the realms (use case: guy looking specifically for wiki articles or gal looking tickets to fix them). If not, probably having a separated "Wiki Tags" and "Tickets Tags" button would be better.

Last edited 6 years ago by saste (previous) (diff)

comment:3 Changed 6 years ago by beastd

  • Resolution set to fixed
  • Status changed from open to closed

Tagging is now enabled for wiki pages too.

Note: See TracTickets for help on using tickets.