Opened 6 years ago

Closed 5 years ago

#3137 closed defect (invalid)

bitrate artifacts with libvpx

Reported by: ubitux Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: libvpx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by ubitux)

When encoding a webm/vp8 with default settings, some weird artifacts appear at regular intervals.

☭ ./ffmpeg -loop 1 -i tests/lena.pnm -vf 'scale=2*iw:2*ih' -t 20 -y out.webm
ffmpeg version N-58093-g54af7ce Copyright (c) 2000-2013 the FFmpeg developers
  built on Nov 14 2013 19:11:51 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-libx264 --enable-libmp3lame --enable-x11grab --enable-libvorbis --samples=/home/ux/fate-samples --enable-libfreetype --enable-libvpx --cpu=native --cc='ccache cc'
  libavutil      52. 53.100 / 52. 53.100
  libavcodec     55. 43.100 / 55. 43.100
  libavformat    55. 21.100 / 55. 21.100
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 91.100 /  3. 91.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Input #0, image2, from 'tests/lena.pnm':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: ppm, rgb24, 256x256, 25 fps, 25 tbr, 25 tbn, 25 tbc
[libvpx @ 0x181a160] v1.2.0
Output #0, webm, to 'out.webm':
  Metadata:
    encoder         : Lavf55.21.100
    Stream #0:0: Video: vp8 (libvpx), yuv420p, 512x512, q=-1--1, 200 kb/s, 1k tbn, 25 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (ppm -> libvpx)
Press [q] to stop, [?] for help
frame=  500 fps=149 q=0.0 Lsize=     434kB time=00:00:20.00 bitrate= 177.9kbits/s    
video:431kB audio:0kB subtitle:0 global headers:0kB muxing overhead 0.898042%

Then play out.webm: at t=5s, t=10s and t=15s, one single frame gets "flashy" (just like if bitrate was wrong/very-low for those frames). It's less visible if bitrate is raised but still visible (try adding -b:v 1M).

It's probably some kind of rate control bug in libvpx, but maybe something is wrong in the wrapper (I don't have time to dig this issue) so I'm opening a ticket.

Change History (1)

comment:1 Changed 5 years ago by ubitux

  • Description modified (diff)
  • Resolution set to invalid
  • Status changed from new to closed
  • Summary changed from bitrate artefacts with libvpx to bitrate artifacts with libvpx

The issue is reproducible with libvpx, I'm closing the issue as it can't be fixed in FFmpeg. See http://code.google.com/p/webm/issues/detail?id=717 for details.

Note: See TracTickets for help on using tickets.