Opened 15 months ago

Closed 10 months ago

Last modified 10 months ago

#2835 closed defect (fixed)

FFMPEG created WTV files stop working with Microsoft Update KB2670838

Reported by: ramitbhalla Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: wtv
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug: WTV files created by ffmpeg stop playing in WMP and Windows MCE when Microsoft Windows Update KB2670838 is installed.
However MCE created WTV files continue to play fine, only ffmpeg created WTV file don't play.

When KB2670838 update is UnInstalled?, MCE and WMP are able to play ffmpeg created WTV files.

I understand WTV is a closed format but is there any way to know why MCE created WTV files play but ffmpeg created WTV files don't play?

Change History (9)

comment:1 Changed 15 months ago by ramitbhalla

BTW, on a related note ffmpeg created WTV files do NOT play on Windows 8 WMP or MCE either.

comment:2 Changed 15 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords wtv added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Audio works fine, looks like a duplicate of ticket #2252.

$ ffmpeg -f lavfi -i testsrc -t 60 out.wtv
ffmpeg version N-55249-ga7bb12a Copyright (c) 2000-2013 the FFmpeg developers
  built on Aug  6 2013 08:47:17 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 40.100 / 52. 40.100
  libavcodec     55. 20.100 / 55. 20.100
  libavformat    55. 13.102 / 55. 13.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 82.100 /  3. 82.100
  libswscale      2.  4.100 /  2.  4.100
  libswresample   0. 17.103 /  0. 17.103
  libpostproc    52.  3.100 / 52.  3.100
Input #0, lavfi, from 'testsrc':
  Duration: N/A, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: rawvideo (RGB[24] / 0x18424752), rgb24, 320x240 [SAR 1:1 DAR 4:3], 25 tbr, 25 tbn, 25 tbc
Output #0, wtv, to 'out.wtv':
  Metadata:
    encoder         : Lavf55.13.102
    Stream #0:0: Video: mpeg2video (mpg2 / 0x3267706D), yuv420p, 320x240 [SAR 1:1 DAR 4:3], q=2-31, 200 kb/s, 10000k tbn, 25 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (rawvideo -> mpeg2video)
Press [q] to stop, [?] for help
frame= 1500 fps=1220 q=9.9 Lsize=    1964kB time=00:00:59.96 bitrate= 268.3kbits/s
video:1750kB audio:0kB subtitle:0 global headers:0kB muxing overhead 12.243855%

comment:3 Changed 15 months ago by ramitbhalla

That's true, audio appears to be playing fine on all platforms, the video is not working. And yes it could be related to the 2252. I'm guess post some update to the windows platform, all devices running that update will not be able to play the wtv video.

comment:4 Changed 13 months ago by ramitbhalla

Any update on this?

comment:5 Changed 11 months ago by jfreiman

I too am having this issue with WTV files. After they are created I can not play them back in either Windows Media Center or Windows Media Player.
I am running Windows 8.1 and can not remove the KB as it does not exist.

comment:6 Changed 11 months ago by p3ngwin

same problem here too on Windows 7.

With the MS Update, "decode Error" and can't play the files, remove the update and everything works fine.

comment:7 Changed 11 months ago by cehoyos

Allow me to try to summarize:

  • MS invented a new media file format "wtv" and did not provide any documentation
  • FFmpeg developers reverse-engineered the format, creating a demuxer and a muxer
  • The muxer worked fine for the codecs it supported
  • The muxer still works fine if you did not update Windows
  • MS changed something within their operating systems (the wtv filter) that makes the files (the muxer) not work anymore

Did anybody report this to Microsoft? Asking for hints how this should be fixed? Sending them a short file that used to work but does not work anymore? The reason I ask is that nobody posted a link to a MS support forum where this is discussed nor some excerpt of an email exchange.
We are of course (very) thankful that this problem was reported here but please understand that there is not much FFmpeg developers can easily do about it. I am not saying MS will help in any way but for those who are interested in this problem the most simple way to go would probably be to (also) report this to MS.

comment:8 Changed 10 months ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Peter Ross in 6da21c1f

comment:9 Changed 10 months ago by ramitbhalla

Thank YOU VERY MUCH PETER ROSS :)

It works like a charm!

Note: See TracTickets for help on using tickets.