Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2383 closed defect (fixed)

ffplay: can't seek ogg with the mouse (or keyboard)

Reported by: ami_stuff Owned by:
Priority: important Component: avformat
Version: git-master Keywords: ogg regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

seeking in attached file does not work for me anymore

git-f6fff8e 25-Feb-2013 - ok
git-5d2f2c7 26-Feb-2013 - bad

The problem (if not reproducibe) may be related to ticket #1874.

C:\>ffplay -cpuflags 0  test.ogg
ffplay version N-51106-g17c1881 Copyright (c) 2003-2013 the FFmpeg developers
  built on Mar 19 2013 13:49:37 with gcc 4.7.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libg
sm --enable-libilbc --enable-libmp3lame --enable-libopencore-amrnb --enable-libo
pencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-li
bschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-lib
twolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enabl
e-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 19.101 / 52. 19.101
  libavcodec     55.  1.100 / 55.  1.100
  libavformat    55.  0.100 / 55.  0.100
  libavdevice    55.  0.100 / 55.  0.100
  libavfilter     3. 47.104 /  3. 47.104
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
    nan A-V:  0.000 fd=  Input #0, ogg, from 'test.ogg':

 0 aq=    0KB vq=   Duration: 00:00:30.01, start:    0KB sq=    0B f0.000000, bi
121 kb/s0/0
    Stream #0:0: Audio: vorbis, 44100 Hz, stereo, fltp, 112 kb/s
    Metadata:
      COMMENT         : Processed by SoX
   4.08 A-V:  0.000 fd=   0 aq=    2KB vq=    0KB sq=    0B f=0/0

Attachments (1)

test.ogg (443.4 KB) - added by ami_stuff 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by ami_stuff

comment:1 Changed 6 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords ogg regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since 5d2f2c7

comment:2 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Michael.

comment:3 Changed 6 years ago by gjdfgh

This was fixed with a format specific hack for ffplay.c in 7f4b588fdfab6085c6398.

But is that hack still needed now that bug #2317 is fixed too, and byte seeking in ogg should work properly?

comment:4 Changed 6 years ago by cehoyos

Patch probably welcome.

Note: See TracTickets for help on using tickets.