Opened 18 months ago

Closed 17 months ago

Last modified 17 months ago

#10133 closed defect (wontfix)

Audio track in TS container not detected

Reported by: kvasa Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -i sample.ts -vn -c:a copy out.aac
ffmpeg 5.1.2

This results in an error:

Output file #0 does not contain any stream

This is because FFmpeg fails to recognize the audio stream in the file - e.g. MediaInfo recognizes the audio correctly.

I am not exactly sure where the issue is, I am attaching the file.

Attachments (1)

sample.ts (630.1 KB ) - added by kvasa 18 months ago.
Sample file to reproduce the issue with.

Download all attachments as: .zip

Change History (4)

by kvasa, 18 months ago

Attachment: sample.ts added

Sample file to reproduce the issue with.

comment:1 by Marton Balint, 17 months ago

Resolution: wontfix
Status: newclosed

By default FFmpeg only analyzes the first 5 seconds of data, and that only contains video. This can be tuned with -analyzeduration if needed. So this works:

ffmpeg -analyzeduration 10000000 -i sample.ts -vn -c:a copy out.aac

It is also worth mentioning that the stream is not properly muxed and has no PAT/PMT. So I don't think anything need to be changed on the ffmpeg side.

comment:2 by Balling, 17 months ago

Yep, in fact mpv does not see audio either as opposed to #8712.

comment:3 by kvasa, 17 months ago

Thank you for looking into this and the suggested solution.

Note: See TracTickets for help on using tickets.