Changes between Version 12 and Version 13 of Encode/AAC


Ignore:
Timestamp:
Jun 13, 2013, 2:32:13 AM (5 years ago)
Author:
cehoyos
Comment:

Simplify and clarify

Legend:

Unmodified
Added
Removed
Modified
  • Encode/AAC

    v12 v13  
    55[[http://en.wikipedia.org/wiki/Advanced_Audio_Coding|Advanced Audio Coding (AAC)]] is the successor format to MP3, and is defined in MPEG-4 part 3 (ISO/IEC 14496-3). It is often used within an MP4 container format; for music the .m4a extension is customarily used. The second-most common use is within MKV (Matroska) files because it has better support for embedded text-based soft subtitles than MP4. The examples in this guide will use the extensions MP4 and M4A. 
    66 
    7 FFmpeg can support four AAC-LC encoders (`aac`, `libfaac`, `libfdk_aac`, `libvo_aacenc`) and two AAC-HE encoders (`libaacplus` and `libfdk_aac`). Although they are all open source, the licenses of `libaacplus`, `libfaac`, and `libfdk_aac` do not provide every freedom of the GPL license (used by other libraries commonly used with ffmpeg), and it is therefore believed that the GPL does not permit redistribution of binaries containing code licensed under these licenses when GPL-licensed code is also included. Therefore these encoders have been designated as "non-free", and you may have trouble finding a pre-built ffmpeg that supports them. This can be resolved by [[CompilationGuide|compiling ffmpeg]]. 
     7FFmpeg can support four AAC-LC encoders (`aac`, `libfaac`, `libfdk_aac`, `libvo_aacenc`) and two AAC-HE encoders (`libaacplus` and `libfdk_aac`). The licenses of `libaacplus`, `libfaac`, and `libfdk_aac` are not compatible with the GPL and distribution of binaries containing code licensed under these licenses when GPL-licensed code is also included is not permitted. Therefore these encoders have been designated as "non-free", and you cannot download a pre-built ffmpeg that supports them. This can be resolved by [[CompilationGuide|compiling ffmpeg]]. 
    88 
    99----