Changes between Version 16 and Version 17 of CompilationGuide/Ubuntu


Ignore:
Timestamp:
Aug 26, 2012, 11:59:50 PM (6 years ago)
Author:
llogan
Comment:

switch from fdk-aac tarball to fdk-aac git; add autoconf and libtool as fdk-aac deps

Legend:

Unmodified
Added
Removed
Modified
  • CompilationGuide/Ubuntu

    v16 v17  
    1616{{{ 
    1717sudo apt-get update 
    18 sudo apt-get -y install build-essential checkinstall git libfaac-dev libgpac-dev \ 
     18sudo apt-get -y install autoconf build-essential checkinstall git libfaac-dev libgpac-dev \ 
    1919  libjack-jackd2-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev \ 
    20   librtmp-dev libsdl1.2-dev libtheora-dev libva-dev libvdpau-dev libvorbis-dev \ 
     20  librtmp-dev libsdl1.2-dev libtheora-dev libtool libva-dev libvdpau-dev libvorbis-dev \ 
    2121  libx11-dev libxfixes-dev pkg-config texi2html yasm zlib1g-dev 
    2222}}} 
     
    2525{{{ 
    2626sudo apt-get update 
    27 sudo apt-get -y install build-essential checkinstall git libfaac-dev libgpac-dev \ 
     27sudo apt-get -y install autoconf build-essential checkinstall git libfaac-dev libgpac-dev \ 
    2828  libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev librtmp-dev libtheora-dev \ 
    29   libvorbis-dev pkg-config texi2html yasm zlib1g-dev 
     29  libtool libvorbis-dev pkg-config texi2html yasm zlib1g-dev 
    3030}}} 
    3131 
     
    5050{{{ 
    5151cd 
    52 wget http://downloads.sourceforge.net/opencore-amr/fdk-aac-0.1.0.tar.gz 
    53 tar xzvf fdk-aac-0.1.0.tar.gz 
    54 cd fdk-aac-0.1.0 
     52git clone --depth 1 git://github.com/mstorsjo/fdk-aac.git 
     53cd fdk-aac 
     54autoreconf -fiv 
    5555./configure 
    5656make 
    57 sudo checkinstall --pkgname=fdk-aac --pkgversion="0.1.0" --backup=no \ 
     57sudo checkinstall --pkgname=fdk-aac --pkgversion="$(date +%Y%m%d%H%M)-git" --backup=no \ 
    5858  --deldoc=yes --fstrans=no --default 
    5959}}} 
     
    161161To remove FFmpeg/x264 and other packages added for this guide: 
    162162{{{ 
    163 sudo apt-get -y autoremove build-essential checkinstall fdk-aac ffmpeg git libfaac-dev libgpac-dev \ 
    164   libjack-jackd2-dev libmp3lame-dev librtmp-dev libsdl1.2-dev libtheora-dev libva-dev libvdpau-dev \ 
     163sudo apt-get -y autoremove autoconf build-essential checkinstall fdk-aac ffmpeg git libfaac-dev libgpac-dev \ 
     164  libjack-jackd2-dev libmp3lame-dev librtmp-dev libsdl1.2-dev libtheora-dev libtool libva-dev libvdpau-dev \ 
    165165  libvorbis-dev libvpx libx11-dev libxfixes-dev pkg-config qt-faststart texi2html x264 yasm zlib1g-dev 
    166166}}}