wiki:

CompilationGuide

/

Quick

/

libx264

In order to quickly compile your libx264, you can type the following commands in your shell:

# cd /my/path/where/i/keep/compiled/stuff
# git clone git://git.videolan.org/x264.git
# cd x264
# ./configure --enable-static --enable-shared
# make
# make install
# ldconfig

If you get a message like this:

Found yasm 0.x.x.xxxx
Minimum version is yasm-1.0.0
If you really want to compile without asm, configure with --disable-asm.

that means that you have an old version of yasm on your system, so you should update it. The quickest way to do so is like this:

# git clone git://github.com/yasm/yasm.git
# cd yasm
# ./autogen.sh
# ./configure
# make
# make install

and after that, just repeat the configure, make, and make install steps for libx264 and it should be fine this time.

Last modified 4 years ago Last modified on Mar 16, 2014, 4:26:51 PM