Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#9954 closed enhancement (duplicate)

Can't decode Bink 2 videos

Reported by: biast12 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: bk2
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by biast12)

Summary of the bug: It doesn't wanna decode Bink 2 videos
How to reproduce:

ffmpeg -i 1.bik -c:v libvpx -b:v 1M -c:a libvorbis -f webm output.wbm

This is the error i get btw

[bink @ 00000184b4761880] Bink 2 video is not implemented

[bink @ 00000184b4761880] Could not find codec parameters for stream 0 (Video: none (KB2i / 0x6932424B), none, 961x530): unknown codec

Consider increasing the value for the 'analyzeduration' (0) and 'probesize' (5000000) options

Input #0, bink, from 'flatline_react_v20_assim_rt02.bik':

Duration: 00:00:25.00, start: 0.000000, bitrate: 6114 kb/s

Stream #0:0[0x0]: Video: none (KB2i / 0x6932424B), none, 961x530, 60 fps, 60 tbr, 60 tbn

Stream mapping:

Stream #0:0 -> #0:0 (? (?) -> vp9 (libvpx-vp9))

Decoder (codec none) not found for input stream #0:0

Attachments (1)

training.bik (604.0 KB ) - added by biast12 21 months ago.
It's a Bink 2 Video

Download all attachments as: .zip

Change History (19)

by biast12, 21 months ago

Attachment: training.bik added

It's a Bink 2 Video

comment:1 by biast12, 21 months ago

Description: modified (diff)

comment:2 by biast12, 21 months ago

Description: modified (diff)

comment:3 by Elon Musk, 21 months ago

Resolution: duplicate
Status: newclosed

in reply to:  3 comment:4 by biast12, 21 months ago

Resolution: duplicate
Status: closedreopened

Replying to Elon Musk:

It's not a normal Bink 2 i'm pretty sure, not even the rad tool knows how to convert it, so no this isn't a duplicate mr "Elon Musk"

comment:5 by Elon Musk, 21 months ago

Resolution: duplicate
Status: reopenedclosed

Clearly says its bink 2 container. Already older ticket open for it.
No need to have millions bink tickets open and be all ignored.

comment:6 by biast12, 21 months ago

Resolution: duplicate
Status: closedreopened

why haven't it then gotten added yet? it has nearly been a year since the first ticket about it, people will continue to make tickets on it if it's never being touched

comment:7 by biast12, 21 months ago

Status: reopenedopen

also i would assume that the rad tool can decrypt a normal bink 2 codex, so can you tell me why it can't decrypt this?

Last edited 21 months ago by biast12 (previous) (diff)

comment:8 by Elon Musk, 21 months ago

Resolution: duplicate
Status: openclosed

It decodes fine here with linux player. You should really contact Epic about issues with their software.

in reply to:  8 comment:9 by biast12, 21 months ago

Resolution: duplicate
Status: closedreopened

Replying to Elon Musk:

It decodes fine here with linux player. You should really contact Epic about issues with their software.

still doesn't change the fact that this have been known for close to a year now without anything being done for it, is it even ever gonna be added?

comment:10 by biast12, 21 months ago

Edit: it was 7 years ago.... https://trac.ffmpeg.org/ticket/4976

comment:11 by biast12, 21 months ago

even looks like they did add "bink 2" support, but there's other versions of it.... = likely what this is

so no... again it's not a duplicate ticket...

comment:12 by biast12, 21 months ago

Status: reopenedopen

comment:13 by Elon Musk, 21 months ago

Resolution: wontfix
Status: openclosed

OK, after ignoring my nice behavior this bug is never going to be fixed, including
older bug report regarding Bink2 files.

Why? The rudeness of users demanding instant solutions and not providing anything in turn is just astonishing.

And you can keep reopening this report as you wish, its now going to be fixed exactly never.

comment:14 by Carl Eugen Hoyos, 21 months ago

Component: ffmpegundetermined
Keywords: bk2 added; Bink2 removed
Resolution: wontfixduplicate

in reply to:  13 comment:15 by biast12, 21 months ago

Resolution: duplicate
Status: closedreopened

Replying to Elon Musk:

OK, after ignoring my nice behavior this bug is never going to be fixed, including
older bug report regarding Bink2 files.

Why? The rudeness of users demanding instant solutions and not providing anything in turn is just astonishing.

And you can keep reopening this report as you wish, its now going to be fixed exactly never.

Ok so it's not gonna be added because people ask for it, that's just on another lvl of childish but sure, and especially because it's only gonna make more people ask for it, like 7 years without it being added.... and the reason behind it is just counterproductive and a childish way of handling it, but i guess it's only gonna be your problem because it's just making more people ask for it

in reply to:  13 comment:16 by biast12, 21 months ago

Replying to Elon Musk:

and not providing anything in turn is just astonishing.

also what do you want us to providing in return? is it money? or what are you asking for? you do sound really greedy but you can't really expect us to do anything other than ask for it to be added, especially because it's such a basic thing

comment:17 by Carl Eugen Hoyos, 21 months ago

Resolution: duplicate
Status: reopenedclosed

Please stop it: It’s neither useful nor necessary.

comment:18 by biast12, 21 months ago

neither is it useful to not add it and ignore / talk to people like this who are just asking for it to be added, is there a place i can talk with the actual devs? so we maybe can get this pushed at some point and not wait 7 years again

Note: See TracTickets for help on using tickets.