Opened 4 years ago

Closed 4 years ago

#973 closed defect (fixed)

FFmpeg MXF problem

Reported by: mareka Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: mxf mpeg12
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Hello,
I have video in mxf format IMX30 or 50Mbit or LongGOP MPEG2/50Mbit.
I want to transcode it to h.264.
I am now using older version of ffmpeg (SVN-r25456-Sherpya) and there are no problems.
Now i want to insert logo using libav filter but newer ffmpeg don't work.
I am getting this error:

  1. when i want transcode IMX30 (SD) - [mpeg2video @ 01C4FAE0] intra matrix invalid, ignoring
  2. LongGOP MPEG2/50Mbit (full HD) - nothing error, but output video is only black

both videos has 200MB together. I can upload it to some server.

Can you someone help me please.
Thank you very much

Attachments (1)

invalidintramatrix.mxf (2.4 MB) - added by cehoyos 4 years ago.

Change History (4)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords changed from mxf, h264 to mxf h264

What is missing to make this a valid ticket:

  • A failing ffmpeg command line
  • Complete, uncut console output
  • And please provide a sample

If you cannot provide a sample, you will have to find the change introducing the problem.

comment:2 Changed 4 years ago by mareka

Videos with FFmpeg builds are here: http://uloz.to/13062440/mxf-zip

CMD - N-34906-g4e7b3ef windows 32bit:

ffmpeg.exe -i c942553.mxf -deinterlace -an -vcodec libx264 -fpre libx264-medium.ffpreset -fpre libx264-baseline.ffpreset -bufsize 8000k -b 3500k -minrate 3500k -maxrate 3500k -crf 22 -s 1280x720 -threads 0 -y video.mp4

Output:

ffmpeg.exe -i c942553.mxf -deinterlace -an -vcodec libx264 -fpre libx264
-medium.ffpreset -fpre libx264-baseline.ffpreset -bufsize 8000k -b 3500k -minrate 3500k -maxrate 3500k -crf 22
 -s 1280x720 -threads 0 -y video.mp4
ffmpeg version N-34906-g4e7b3ef, Copyright (c) 2000-2011 the FFmpeg developers
  built on Nov 16 2011 12:35:07 with gcc 4.6.2
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-runtime-cpudetect --enable-avisy
nth --enable-bzlib --enable-frei0r --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libfreetype
--enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-li
bspeex --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --e
nable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil    51. 25. 0 / 51. 25. 0
  libavcodec   53. 34. 0 / 53. 34. 0
  libavformat  53. 20. 0 / 53. 20. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 48. 1 /  2. 48. 1
  libswscale    2.  1. 0 /  2.  1. 0
  libpostproc  51.  2. 0 / 51.  2. 0
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 1 times
Input #0, mxf, from 'c942553.mxf':
  Duration: 00:00:10.00, start: 0.000000, bitrate: 62576 kb/s
    Stream #0:0: Video: mpeg2video (4:2:2), yuv422p, 720x608 [SAR 152:135 DAR 4:3], 50000 kb/s, 25 fps, 25 tbr
, 25 tbn, 50 tbc
    Stream #0:1: Audio: pcm_s16le, 48000 Hz, 2 channels, s16, 1536 kb/s
Please use -b:a or -b:v, -b is ambiguous
[buffer @ 03E95F20] w:720 h:608 pixfmt:yuv422p tb:1/1000000 sar:152/135 sws_param:
[scale @ 03E95FE0] w:720 h:608 fmt:yuv422p -> w:1280 h:720 fmt:yuv422p flags:0x4
[libx264 @ 038C0740] using SAR=3/4
[libx264 @ 038C0740] using cpu capabilities: MMX2 SSE2Fast SSSE3 Cache64
[libx264 @ 038C0740] profile High 4:2:2, level 3.1, 4:2:2 8-bit
[libx264 @ 038C0740] 264 - core 118 r2085 8a62835 - H.264/MPEG-4 AVC codec - Copyleft 2003-2011 - http://www.v
ideolan.org/x264.html - options: cabac=0 ref=3 deblock=1:0:0 analyse=0x1:0x111 me=hex subme=7 psy=0 mixed_ref=
1 me_range=16 chroma_me=1 trellis=1 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=0 threads=3 sl
iced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=250
 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=0 crf=22.0 qcomp=0.60 qpmin=10 qpmax=
51 qpstep=4 vbv_maxrate=3500 vbv_bufsize=8000 crf_max=0.0 nal_hrd=none ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'video.mp4':
  Metadata:
    encoder         : Lavf53.20.0
    Stream #0:0: Video: h264 (![0][0][0] / 0x0021), yuv422p, 1280x720 [SAR 3:4 DAR 4:3], q=10-51, 3500 kb/s, 2
5 tbn, 25 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (mpeg2video -> libx264)
Press [q] to stop, [?] for help
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 19 times
intra matrix invalid, ignoring=       0kB time=00:00:00.00 bitrate=   0.0kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 17 times
intra matrix invalid, ignoring=       0kB time=00:00:00.00 bitrate=   0.0kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 4 times
intra matrix invalid, ignoring=       0kB time=00:00:00.00 bitrate=   0.0kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=      40kB time=00:00:00.16 bitrate=2035.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 1 times
intra matrix invalid, ignoringe=      70kB time=00:00:00.28 bitrate=2059.6kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 4 times
intra matrix invalid, ignoringe=     184kB time=00:00:00.52 bitrate=2902.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=     272kB time=00:00:00.72 bitrate=3096.7kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=     365kB time=00:00:00.92 bitrate=3247.2kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=     429kB time=00:00:01.08 bitrate=3254.4kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=     481kB time=00:00:01.24 bitrate=3179.9kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=     529kB time=00:00:01.40 bitrate=3098.2kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 4 times
intra matrix invalid, ignoringe=     645kB time=00:00:01.64 bitrate=3221.5kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 5 times
intra matrix invalid, ignoringe=     789kB time=00:00:01.92 bitrate=3366.1kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 5 times
intra matrix invalid, ignoringe=     954kB time=00:00:02.20 bitrate=3550.5kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 1 times
intra matrix invalid, ignoringe=    1006kB time=00:00:02.32 bitrate=3551.2kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1040kB time=00:00:02.48 bitrate=3435.5kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1068kB time=00:00:02.64 bitrate=3312.7kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1099kB time=00:00:02.84 bitrate=3171.5kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1131kB time=00:00:03.04 bitrate=3046.8kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1160kB time=00:00:03.20 bitrate=2970.4kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1196kB time=00:00:03.40 bitrate=2880.9kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1223kB time=00:00:03.56 bitrate=2813.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1255kB time=00:00:03.76 bitrate=2734.5kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1280kB time=00:00:03.92 bitrate=2674.9kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1304kB time=00:00:04.08 bitrate=2618.5kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1328kB time=00:00:04.24 bitrate=2565.8kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1352kB time=00:00:04.40 bitrate=2517.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1383kB time=00:00:04.60 bitrate=2463.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1435kB time=00:00:04.80 bitrate=2449.8kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1465kB time=00:00:05.00 bitrate=2399.6kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1488kB time=00:00:05.16 bitrate=2362.7kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1517kB time=00:00:05.36 bitrate=2318.7kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1546kB time=00:00:05.56 bitrate=2278.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1569kB time=00:00:05.72 bitrate=2247.4kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1592kB time=00:00:05.88 bitrate=2218.6kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 4 times
intra matrix invalid, ignoringe=    1627kB time=00:00:06.12 bitrate=2177.2kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1655kB time=00:00:06.32 bitrate=2145.6kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1678kB time=00:00:06.48 bitrate=2121.0kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1706kB time=00:00:06.68 bitrate=2092.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1729kB time=00:00:06.84 bitrate=2070.4kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1758kB time=00:00:07.04 bitrate=2045.4kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1780kB time=00:00:07.20 bitrate=2025.7kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1809kB time=00:00:07.40 bitrate=2002.3kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 2 times
intra matrix invalid, ignoringe=    1831kB time=00:00:07.56 bitrate=1984.6kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 1 times
intra matrix invalid, ignoringe=    1848kB time=00:00:07.68 bitrate=1971.6kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 4 times
intra matrix invalid, ignoringe=    1882kB time=00:00:07.92 bitrate=1946.9kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 3 times
intra matrix invalid, ignoringe=    1910kB time=00:00:08.12 bitrate=1926.9kbits/s
[mpeg2video @ 01BDFAE0] intra matrix invalid, ignoring
    Last message repeated 1 times
frame=  250 fps=  8 q=-1.0 Lsize=    2174kB time=00:00:10.00 bitrate=1780.7kbits/s
video:2171kB audio:0kB global headers:0kB muxing overhead 0.124286%
[libx264 @ 038C0740] frame I:35    Avg QP:18.33  size: 21734
[libx264 @ 038C0740] frame P:215   Avg QP:18.28  size:  6799
[libx264 @ 038C0740] mb I  I16..4: 88.6%  0.0% 11.4%
[libx264 @ 038C0740] mb P  I16..4:  5.6%  0.0%  0.5%  P16..4: 34.7%  5.5%  1.0%  0.0%  0.0%    skip:52.7%
[libx264 @ 038C0740] coded y,uvDC,uvAC intra: 17.5% 78.3% 17.0% inter: 3.0% 27.3% 0.3%
[libx264 @ 038C0740] i16 v,h,dc,p: 26% 29% 16% 29%
[libx264 @ 038C0740] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 23% 21% 34%  5%  3%  3%  3%  5%  2%
[libx264 @ 038C0740] i8c dc,h,v,p: 35% 25% 19% 21%
[libx264 @ 038C0740] ref P L0: 41.5% 29.5% 28.9%
[libx264 @ 038C0740] kb/s:1777.93

Changed 4 years ago by cehoyos

comment:3 Changed 4 years ago by cehoyos

  • Keywords mpeg12 added; h264 removed
  • Priority changed from important to normal
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from 0.10 to git-master

I silenced the extensive warnings (they are now only shown for loglevel debug).

If you have any problems with the other video (I was unable to reproduce), please open a new ticket.

Note: See TracTickets for help on using tickets.