#9533 closed defect (invalid)

Shared build Error

Reported by: Charles F. Schatz Owned by:
Priority: normal Component: build system
Version: git-master Keywords: Linux build
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Summary of the bug:
How to reproduce:

% ./configure --enable-gpl --enable-nonfree --enable-ffplay --enable-libass --enable-libfdk-aac --enable-libsvtav1 --enable-libopus --enable-libdav1d --enable-libx264 --enable-libx265 --disable-hwaccel=hevc_vdpau --disable-hwaccel=hevc_vaapi --disable-hwaccel=av1_vaapi --enable-libtesseract --enable-libzvbi --disable-decoder=hevc_v4l2m2m --disable-encoder=hevc_vaapi --disable-encoder=hevc_v4l2m2m --enable-opencl --disable_static --enable-shared


./ffmpeg: error while loading shared libraries: libavdevice.so.59: cannot open shared object file: No such file or directory

This is consistent across at least the last several snapshots.

Attachments (1)

ffmpeg_diag.txt (47.0 KB ) - added by Charles F. Schatz 22 months ago.
Release/Version 4.4.1 Diagnostics

Download all attachments as: .zip

Change History (7)

comment:1 by mkver, 22 months ago

Is it possible that you have an rpath/runpath issue and that the binaries that have been built just can't be found by the dynamic loader?
(When was the last snapshot that it worked? Was it before the last major version bump?)

comment:2 by Charles F. Schatz, 22 months ago

I have been using a recent master copy via direct download and 'git' copies via http with the same result. I shall try to download an older version or two.

comment:3 by Charles F. Schatz, 22 months ago

I have downloaded sources ffmpeg 4.0, 4.1, 4.2, 4.3, 4.4 and 4.4.1. Ffmpeg 4.4.1 is my current build source.

It appears that ONLY ffmpeg 4.4.1 has broken the shared library mechanism on debian (Bullseye) linux. I built each of the listed versions and the only source that reproduces the un-found shared library as reported is ffmpeg 4.4.1.


comment:4 by mkver, 22 months ago

What is the commit hash of your FFmpeg 4.4.1? And where are the libraries located and where are the libraries searched (use LD_DEBUG=libs)?

by Charles F. Schatz, 22 months ago

Attachment: ffmpeg_diag.txt added

Release/Version 4.4.1 Diagnostics

comment:5 by Charles F. Schatz, 22 months ago

The ffmpeg code I compile was a snapshot from 1 November - it produces less output from compiling processes than 4.4.1 or 4.4, which produce enormous amounts of support libraries such as post-processing. The banner from 4.4 and 4.4.1 is huge, if not disconcerting.

comment:6 by mkver, 22 months ago

Resolution: invalid
Status: newclosed

The output confirms that the library can just not be found by the dynamic linker. This is not a bug in FFmpeg; set an rpath or use LD_LIBRARY_PATH or install the libraries in a directory searched by the dynamic linker.

Note: See TracTickets for help on using tickets.