Opened 9 months ago

Closed 5 months ago

#9511 closed defect (fixed)

TrueHD decoding fail...

Reported by: K.Y.H Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords: thd, mlp
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by Hendrik)

ffmpeg -i \[Beatrice-Raws\]\ Log\ Horizon\ -\ Entaku\ Houkai\ 01\ \[BDRip\ 1920x1080\ HEVC\ TrueHD\].mkv 123.mkv

configuration:
libavutil 57. 8.100 / 57. 8.100
libavcodec 59. 12.100 / 59. 12.100
libavformat 59. 8.100 / 59. 8.100
libavdevice 59. 0.101 / 59. 0.101
libavfilter 8. 16.102 / 8. 16.102
libswscale 6. 1.100 / 6. 1.100
libswresample 4. 0.100 / 4. 0.100

[truehd @ 042edd40] Assignment of matrix channel 0 to invalid output channel -22 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[truehd @ 042edd40] If you want to help, upload a sample of this file to https://streams.videolan.org/upload/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[truehd @ 042edd40] No restart header present in substream 0.
[truehd @ 042edd40] No samples to output.
Input #0, matroska,webm, from '[Beatrice-Raws] Log Horizon - Entaku Houkai 01 [BDRip 1920x1080 HEVC TrueHD].mkv':

Metadata:

encoder : libebml v1.4.2 + libmatroska v1.6.4
creation_time : 2021-07-30T01:18:37.000000Z

Duration: 00:24:32.81, start: 0.000000, bitrate: 10135 kb/s
Chapters:

Chapter #0:0: start 0.000000, end 61.978578

Metadata:

title : Avant

Chapter #0:1: start 61.978578, end 152.026867

Metadata:

title : OP

Chapter #0:2: start 152.026867, end 664.080067

Metadata:

title : Part A

Chapter #0:3: start 664.080067, end 1355.020333

Metadata:

title : Part B

Chapter #0:4: start 1355.020333, end 1444.985200

Metadata:

title : ED

Chapter #0:5: start 1444.985200, end 1472.805000

Metadata:

title : Next

Stream #0:0(jpn): Video: hevc (Main 10), yuv420p10le(tv, bt709), 1920x1080, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn (default)

Metadata:

title : BDrip by Jensen
BPS : 9236088
DURATION : 00:24:32.805000000
NUMBER_OF_FRAMES: 35312
NUMBER_OF_BYTES : 1700369724
_STATISTICS_WRITING_APP: mkvmerge v59.0.0 ('Shining Star') 64-bit
_STATISTICS_WRITING_DATE_UTC: 2021-07-30 01:18:37
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Stream #0:1(jpn): Audio: truehd, 48000 Hz, stereo, s32 (24 bit) (default)

Metadata:

BPS : 792310
DURATION : 00:24:32.805000000
NUMBER_OF_FRAMES: 1767366
NUMBER_OF_BYTES : 145864922
_STATISTICS_WRITING_APP: mkvmerge v59.0.0 ('Shining Star') 64-bit
_STATISTICS_WRITING_DATE_UTC: 2021-07-30 01:18:37
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Stream #0:2(eng): Subtitle: ass (default)

Metadata:

title : Eng
BPS : 943
DURATION : 00:24:25.120000000
NUMBER_OF_FRAMES: 1340
NUMBER_OF_BYTES : 172786
_STATISTICS_WRITING_APP: mkvmerge v59.0.0 ('Shining Star') 64-bit
_STATISTICS_WRITING_DATE_UTC: 2021-07-30 01:18:37
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Stream #0:3(jpn): Subtitle: hdmv_pgs_subtitle, 1920x1080 (original)

Metadata:

title : Jpn
BPS : 110894
DURATION : 00:24:27.091000000
NUMBER_OF_FRAMES: 1418
NUMBER_OF_BYTES : 20336538
_STATISTICS_WRITING_APP: mkvmerge v59.0.0 ('Shining Star') 64-bit
_STATISTICS_WRITING_DATE_UTC: 2021-07-30 01:18:37
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Stream mapping:

Stream #0:0 -> #0:0 (hevc (native) -> mpeg4 (native))
Stream #0:1 -> #0:1 (truehd (native) -> ac3 (native))
Stream #0:2 -> #0:2 (ass (ssa) -> ass (ssa))

Press [q] to stop, ? for help
[truehd @ 041bf040] Assignment of matrix channel 0 to invalid output channel -22 is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.
[truehd @ 041bf040] If you want to help, upload a sample of this file to https://streams.videolan.org/upload/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.
Error while decoding stream #0:1: Invalid data found when processing input
[truehd @ 041bf040] No restart header present in substream 0.
[truehd @ 041bf040] No samples to output.

Change History (10)

comment:1 by Balling, 9 months ago

You are aware that there is no need to mention trackers? DHT is more than enough.

Was the file created with ffmpeg or Plex ffmpeg?

in reply to:  1 comment:2 by K.Y.H, 9 months ago

Replying to Balling:

You are aware that there is no need to mention trackers? DHT is more than enough.

Was the file created with ffmpeg or Plex ffmpeg?

I don't know~
Someone reported to me.
So I wrote a bug on FFmpeg

by Hendrik, 8 months ago

Attachment: truehd_regression.mlp added

comment:3 by Hendrik, 8 months ago

Description: modified (diff)
Reproduced by developer: set
Status: newopen

I've attached another sample with the same problem, a stereo truehd stream from a Blu-ray disc.

This is a regression since 57f0b36367d4e5ccd4d2da7f69c3cac45b6236ee

comment:5 by Balling, 8 months ago

a8a7c5d502a851d16c4668e03bff12d0e16c32b8 does not fix the issue, ffplay plays garbage but warnings are gone, Mono.mlp is still broken. Regression on regression.

comment:6 by Balling, 8 months ago

Keywords: thd added; truehd removed

Corrected keyword.

comment:7 by Balling, 6 months ago

Okay, will clarify that ffplay is the only thing that is affected. The ffmpeg as an application (LOL) is not affected. Except for Mono.mlp.

comment:8 by Elon Musk, 5 months ago

Resolution: fixed
Status: openclosed
Note: See TracTickets for help on using tickets.