#9398 closed defect (invalid)

mpeg4_unpack_bframes don't work in Powershell 7

Reported by: Arnab Animesh Das Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Arnab Animesh Das Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: When mpeg4_unpack_bframes bitstream filter is run in Powershell it shows the following error:

[NULL @ 00000235ef2ebd00] Unable to find a suitable output format for 'mpeg4_unpack_bframes'
mpeg4_unpack_bframes: Invalid argument

In the command prompt, it works fine. I am using Windows 10 x64 21H1. You can use any avi video for this purpose.

How to reproduce:

% ffmpeg -i i.avi -bsf:v mpeg4_unpack_bframes -codec copy o.avi
ffmpeg version n4.4-78-g031c0cb0b4-20210709 Copyright (c) 2000-2021 the FFmpeg developers
  built with gcc 10-win32 (GCC) 20210408

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (2)

i.avi (2.3 MB ) - added by Arnab Animesh Das 10 months ago.
Input file
ffmpeg.ps1 (273 bytes ) - added by Arnab Animesh Das 10 months ago.
ffmpeg scoop script

Change History (6)

by Arnab Animesh Das, 10 months ago

Attachment: i.avi added

Input file

comment:1 by Balling, 10 months ago

Resolution: invalid
Status: newclosed

Usual problem, use absolute path since some other version of ffmpeg is in your PATH.

And your normal ffmpeg is compiled with mpeg4_unpack_bframes support.
Tested with latest not as part of windows powershell stable 7.1.4, it works.

% ffmpeg

There is no such thingy in windows. Are you using WSL?

Last edited 10 months ago by Balling (previous) (diff)

by Arnab Animesh Das, 10 months ago

Attachment: ffmpeg.ps1 added

ffmpeg scoop script

in reply to:  1 comment:2 by Arnab Animesh Das, 10 months ago

Resolution: invalid
Status: closedreopened

Replying to Balling:

Usual problem, use absolute path since some other version of ffmpeg is in your PATH.

And your normal ffmpeg is compiled with mpeg4_unpack_bframes support.
Tested with latest not as part of windows powershell stable 7.1.4, it works.

% ffmpeg

There is no such thingy in windows. Are you using WSL?

I installed ffmpeg via scoop which created one shim named ffmpeg.exe (%USERPROFILE%\scoop\shims\ffmpeg.exe) and another script ffmpeg.ps1 in the same folder. When I run it via PowerShell it runs ffmpeg.ps1 and hence the issue occurs. But this is the only time I have had to face such issue, ffmpeg works fine in other scenarios.

comment:3 by Arnab Animesh Das, 10 months ago

I have also opened a ticket at scoop end:

https://github.com/ScoopInstaller/Main/issues/2611

comment:4 by Arnab Animesh Das, 10 months ago

Resolution: invalid
Status: reopenedclosed

Closing the issue as it is a scoop/shell issue.

Note: See TracTickets for help on using tickets.