#9301 closed defect (worksforme)

"-c copy" is very slow

Reported by: ConcludingPrague Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg -i input.m4a -c copy output.m4a

Input file is 350MB, 6 hours.

The old ffmpeg-20191214-24424a6-win64-shared.zip did it in 4 seconds:

ffmpeg version git-2019-12-14-24424a6 Copyright (c) 2000-2019 the FFmpeg developers
size= 357940kB time=06:17:43.92 bitrate= 129.4kbits/s speed=6.3e+03x

While the newer git-2020-05-22-38490cb, 4.4-full_build-www.gyan.dev, n4.4-73-g7015704640 took 29 seconds!

ffmpeg version n4.4-73-g7015704640 Copyright (c) 2000-2021 the FFmpeg developers
size= 357940kB time=06:17:43.92 bitrate= 129.4kbits/s speed= 781x

"-report -v 9 -loglevel 99" creates a huge log over 200MB

Sample:
https://www.youtube.com/watch?v=triXo_xCqms format 140 (AAC DASH)
http://www.solidfiles.com/v/6GkdZme7kLQLD
https://1fichier.com/?ukqq2zh0jm4yvd4iqapf

Change History (1)

comment:1 by Carl Eugen Hoyos, 12 months ago

Resolution: worksforme
Status: newclosed

For future tickets please remember to always test current FFmpeg git head, the only version supported on this bug tracker, and always provide the command line you tested together with the complete, uncut console output.
I cannot reproduce a performance regression for the given command line between 24424a65 and 38490cbe.

Note: See TracTickets for help on using tickets.