#9279 closed defect (fixed)

Vulkan hw device ctx reports a segmentation fault when initialize the device context.

Reported by: wenbin,chen Owned by:
Priority: normal Component: avutil
Version: git-master Keywords: vulkan
Cc: wenbin,chen Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by wenbin,chen)

Summary of the bug:
How to reproduce:

ffmpeg -init_hw_device vulkan=vul:0 -filter_hw_device vul -i 1080P.264 -vf "hwupload=extra_hw_frames=16,scale_vulkan=w=1920:h=1080" -f null -

Error occurs at https://github.com/FFmpeg/FFmpeg/blob/2fac1e370c9cf48b2e9d4a7f2c0d7236017f9bbe/libavutil/hwcontext_vulkan.c#L1018
The CreateCommandPool function is not loaded, so the function pointer is NULL.

I think the code in https://github.com/FFmpeg/FFmpeg/blob/2fac1e370c9cf48b2e9d4a7f2c0d7236017f9bbe/libavutil/hwcontext_vulkan.c#L1352 should be changed to

err = load_functions(ctx, 1, 1);

Change History (2)

comment:1 by wenbin,chen, 16 months ago

Description: modified (diff)

comment:2 by wenbin,chen, 16 months ago

Resolution: fixed
Status: newclosed

The issue is fixed in the latest master.

Note: See TracTickets for help on using tickets.